0

I am running kali linux as a virtual machine in virtualbox, but when I click zenmap it does not open and nothing shows up, I have tried reinstalling it but the problem remains same.

when I run zenmap in terminal it shows: /usr/bin/env: ‘python’: No such file or directory

2
  • Obviously, Python is not installed or not in the PATH. – berndbausch Apr 22 at 10:14
  • I have installed python3 but how do I add it to PATH in linux?? – Ojasva Nema Apr 22 at 11:46
0

First, you need a program named python. I just checked on my Kali installation (WSL2 running in Windows) and found that, indeed, it doesn't have python out of the box. So, create a symbolic link ln -s /usr/bin/python3 /usr/bin/python, assuming that /usr/bin/python3 is correct.

Normally, your PATH should contain /usr/bin. No need to change it.

0

zenmap has been removed from Kali Linux.

Here is the answer of Kali maintainer @Gamb1t on kali forum.

As zenmap was not being maintained upstream any longer we had to drop the package.

Zenmap is the nmap GUI, you should use nmap as alternative.

nmap documentation.

2
  • So now what I have to learn nmap the commandline of zenmap or is there is any way?? – Ojasva Nema Apr 22 at 12:47
  • @OjasvaNema Answer updated, nmap is the alternative. nmap CLI is more powerful. – GAD3R Apr 22 at 14:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.