0

I am trying to install the latest Node on my Linux system by running the following terminal command, I keep getting the following error. tar: You may not specify more than one '-Acdtrux', '--delete' or '--test-label' option Try 'tar --help' or 'tar --usage' for more information. This terminal command I copied right off a website.

tar -C /usr/local –strip-components 1 -xJf node-v12.13.1-linux-x64.tar.xz
2

You command should be something like:

tar -C /usr/local --strip-components=1 -xJf node-v12.13.1-linux-x64.tar.xz

but to simplicity you can use:

cd /usr/local
tar --strip-components=1 -xJf /path/to/node-v12.13.1-linux-x64.tar.xz

Also check if you really need --strip-components

P.S. You may need syntax like this: --strip-components 1

6
  • 1
    You are correct that I don't need --strip-components. Once it installed I did a check to see if it took the installation by running node -v. It is still showing its previous version I installed. Do I need to restart the system?
    – ThN
    Apr 21 at 18:36
  • @ThN, no, you do not need to restart. Apr 21 at 18:51
  • Try to go to in to bin directory and execute it on this way: ./node -v Apr 21 at 18:57
  • This installation did not install in the folder /usr/bin. It is in /usr/local/bin. I was able to execute it, but only after I provided its exact location.
    – ThN
    Apr 21 at 19:12
  • 1
    If you are right with that needed = , I would recommend to file a bug against the option parser.
    – schily
    Apr 25 at 13:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.