0

I Recently started using linux, and picked Deepin as my distro as a recommendation from my teacher. I love this distro a lot. I use it to work and to game too.

I was using Deepin 20.1 and proton and steam worked fine, wine too. But then 20.2 was released. I was excited with a new software upgrade, so i upgraded my system and im now using 20.2.

But now my proton dosen't work properly anymore. The games start just fine, but the graphics are glitched out.This happens with all of my installed 3D games that require proton!

Here's an example with Bioshock Remastered:

https://i.sstatic.net/a2qjf.jpg

As with all of my 3d games before the upgrade, it worked fine, but now the graphics are a mess.

(Native Linux 3D games like PAYDAY 2 and Dying Light are working fine).

This also happens on Warframe, GTA V, The Forest and many other 3D Games (Some games work if i use PROTON_USE_WINED3D=1 %command%, but some games crash with this launch opption).

What i have tried so far:

-Reinstalling Steam;

-Reinstalling Wine;

-Reinstaling Deepin 20.2 (clean install);

-Tried both Wine Staging and Wine stable from WineHQ;

-Tried updating and reinstaling gpu drivers. (both mesa-vulkan and mesa-vulkan x32);

-Tried many versions of Proton, from 4 to Proton GE 6.3;

Deepin 20.2 is based on Debian 10.8 (Buster) and uses the 5.10 LTS Kernel.

My GPU is an AMD Radeon R7 240 with 2GB of VRAM.

I anyone can provide me with some extra guidance or knows about a solution, please leave a comment below. (I have been searching for a solution for 5 days and i am going crazy).

1 Answer 1

0

I was able to finally solve this with some help from Reddit. Turns out Deepin's repository does not provide the latest version of mesa, so i had to upgrade mesa from another PPA. I managed to make everything work on Deepin 20.2 by using kisak-mesa. Instructions on how to install it can be found here. For my OS, i had to modify the ppa line to deb http://ppa.launchpad.net/kisak/kisak-mesa/ubuntu bionic main in my sources.list. Hope this helps anyone who had graphics issues.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .