1

I had a USB drive mounted on /dev/sdb1 and I want to reformat from NTFS to ext3. I did umount -l which unmounted the disk. I deleted the old partition using cfdisk. I ran mkfs.ext3, but got the error:

/dev/sdb1 is apparently in use...

After googling I tried to cat /proc/mounts and found it there:

/dev/sdb1 /media/moviesold 

How do I remove the reference from there? How did it get there? More specifically what can I run to "really umount"?

4

Use umount. You ran umount -l, which specifically tells umount to leave the filesystem mounted until all processes are done with it. You really shouldn't need umount -l most of the time; the only purpose it serves is freeing up the mount point so you can mount something new there while the currently mounted partition is still in use. Now that you've already lazy unmounted it, if you figure out which process still has a file open on the filesystem and close it it will unmount automatically

  • Thanks, I thought the -l meant "force unmount" for some reason. I still cant format but that is a separate question. – cjburkha Feb 13 '13 at 12:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.