1

enter image description here

I was trying to make it normal from grub rescue error. But, msdos7 is returning that filesystem is ext2. When I write insmod normal I get "invalid file name 'hd0,msdos7/i386-pc/normal.mod"

How can I fix it? I have bootable USB . that's arch Linux. Even, I tried by bootable USB also. When I reboot my laptop that(grub Loader) don't show anymore(like it had erased automatically when rebooting). I was following the answer https://askubuntu.com/a/462995

When I tried to search search.file ... I got an error unknown command 'search.file'.

enter image description here

root@mint:~# fdisk -l
Disk /dev/loop0: 1.8 GiB, 1912557568 bytes, 3735464 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/sda: 298.9 GiB, 320072933376 bytes, 625142448 sectors
Disk model: Hitachi HTS72323
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xcdead0a2

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sda1  *      1026048 272532369 271506322 129.5G  7 HPFS/NTFS/exFAT
/dev/sda2       272533504 273694719   1161216   567M 27 Hidden NTFS WinRE
/dev/sda3       273696768 274747391   1050624   513M  b W95 FAT32
/dev/sda4       274747392 625142447 350395056 167.1G  5 Extended
/dev/sda5       274749440 275726335    976896   477M ef EFI (FAT-12/16/32)
/dev/sda6       275728384 277682175   1953792   954M 82 Linux swap / Solaris
/dev/sda7       277684224 625142447 347458224 165.7G 83 Linux

This is how I installed grubloader but, I am getting the grub error although. /dev/sda7 is arch Linux. And, /dev/sda1 is windows.

I had Kali earlier. I had deleted partition/volume of kali,swap and grub from windows manager.

enter image description here

I noticed that type /dev/sda7 is ext2. But, I remember that I formatted it to ext4.

Now, I have Linux Mint bootable USB.

root@mint:~# mount /dev/sda5 /mnt
mount: /mnt: /dev/sda5 already mounted on /mnt.
root@mint:~# grub-install /dev/sda5
Installing for i386-pc platform.
grub-install: error: failed to get canonical path of `/cow'.

[![enter image description here][4]][4]

I was following the video. I notice that he set flags to bios_grub. But, I don't have bios_grub. What to do now?

0
0

By following the video I had solved this issue.

sudo mount /dev/sda7 /mnt
sudo mount --bind /dev /mnt/dev
sudo mount --bind /proc /mnt/proc
sudo mount --bind /sys /mnt/sys
sudo chroot /mnt
grub-install /dev/sda
sudo umount /mnt/dev
sudo umount /mnt/proc
sudo umount /mnt/sys
sudo umount /mnt
reboot now

But, I am facing another issue here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy