0

I tried grub-install --target=x86_64-efi --efi-directory=/b

I got output...

failed to get canonical path of /b

I don't know why this is happening? How can I fix it?

3
  • Do you have a directory /b?
    – roaima
    Apr 19 at 13:23
  • 1
    @roaima sorry I didn't answer my question. I had already fixed the problem but, I can't use SE properly in mobile that's why I didn't answer. I was thinking to answer all of my question which I created currently I am facing the issue unix.stackexchange.com/questions/645797/…. I request to check it... I am answering those questions which I solved
    – user467213
    Apr 19 at 13:32
  • 1
    @roaima I have added lot more information in that question please check it now...
    – user467213
    Apr 19 at 14:09
0

Actually, grub-install --target=x86_64-efi --efi-directory=/b doesn't have access to run as a normal user. This only can be run as root user(arch-chroot). Here's the answer which helped me https://unix.stackexchange.com/a/261409/467213. And, not every user can run the code grub-install --target=x86_64-efi --efi-directory=/b. I tried to run the code as a root user I got another issue. Here's the question which helped me https://bbs.archlinux.org/viewtopic.php?id=252598. I am unable to copy the answer(cause, I am using SE from mobile. I will edit my answer later.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy