1

I am trying to boot into Ubuntu system 20.04 LTS. However, every time I turn on, for about 5 seconds loading something, then it suddenly shuts down.  It then automatically restarts, loading and shutting down .. continue in a loop.  However, if I go into Grub, I can log into the recover mode and get access the root command line interface.

Can anyone help me troubleshoot this strange thing?

The following are the only things that are set up in my computer build right now:

  • Motherboard: Z590 MSI PRO Wi-Fi
  • CPU: i9-10850k and a CPU fan
  • RAM: a pair of 16 GB
  • M.2 SSD: Samsung 980 Pro NVMe
  • Power supply: EVGA 700 GD, 80+ GOLD 700W

UPDATE:

Currently, What I have tried which can log into the OS and even the user interface is to edit the Ubuntu option in GRUB. However, only before 5 minutes the computer shuts down itself.

Specifically, I added $vt_handoff nomodeset. When loading, I found that it keeps saying that Bluetooth hc10: reading intel version information failed (-22)

6
  • Inspect recently modified log files ls -lc /var/log. Copy them to USB stick and examine elsewhere. How's your power supply? – waltinator Apr 18 at 3:25
  • Can you try to check systemctl list-unit-files | grep enabled There could be a service causing the shutdown e.g. malware – Microwave Dude Apr 18 at 7:27
  • @waltinator my power supply is EVGA 700 GD, 80+ GOLD 700W – Lala James Apr 18 at 14:49
  • @waltinator Currently, I cannot even go to recovery mode and the root command line interface. Grub interface is the only interface that does not shut me down. any change to see the modified log files? – Lala James Apr 18 at 15:08
  • Nope. All I can suggest is hardware flakiness. Can you reboot into memtest86+ and run tests for a few hours? Reseat everything? Clean contacts? Check for obstructions in sockets? Search the error message online? – waltinator Apr 18 at 17:10
0

I solved the issue.

It seems that there are extra steps that finally make my new computer boot successfully. Here is how I solved this issue completely (I hope).

  1. buy a new power supply. I bet the original one is defective which may explain it shuts down immediately after post/grub every time.

  2. In the Grub mode, I modified the argument by adding nomodeset at the end of the lien of linux argument.

One may search for nomodeset via google to see related information. As a matter of fact, the safe graphic mode for installation includes nomodeset.

See reference: https://askubuntu.com/questions/1085807/black-screen-after-installation-of-ubuntu-18-04

  1. After I successfully installed (using safe graphic mode) and use nomodeset argument when boot in, Wifi and Bluetooth cannot use. And I donot want to use nomodeset every time. Fortunately I have Ethernet cable. I follow this link https://forums.linuxmint.com/viewtopic.php?t=346412 and install linux-oem-20.04b via sudo apt install linux-oem-20.04b in the terminal.

From install to complete:

  1. in Grub mode use safe graphic mode to install.

  2. When boot into the installed Ubuntu, add nomodeset.

  3. Open terminal and enter sudo apt install linux-oem-20.04b.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.