I downloaded GParted live archive and extracted it to /dev/sda4. The GParted guide explains installation with grub, but since I'm not using grub I wanted to give it a shot adding a manual entry to rEFInd. This is the pratition tree.

sda                                   111.8G disk 
├─sda1                    Recovery      499M part ntfs
├─sda2                                   99M part vfat
├─sda3                                   16M part 
├─sda4                    ARCH_202104  16.1G part vfat
└─sda5                    Data         95.1G part ntfs
sdb                                   931.5G disk 
├─sdb1                                    1M part 
├─sdb2                                   15M part 
├─sdb3                    Main        833.8G part ntfs
└─sdb4      /mnt/ArchData              97.7G part ext4
nvme0n1                               931.5G disk 
├─nvme0n1p1                              16M part 
├─nvme0n1p2               Main M.2      433G part ntfs
└─nvme0n1p3 /             Arch        494.6G part ext4

rEFInd is installed on sda2 and GParted is on sda4(ARCH_202104) and in refind.conf I've added an entry like so:

menuentry "GParted Live" {
    icon     /EFI/refind/icons/os_linux.png
    volume   "ARCH_202104"
    loader   /live/vmlinuz
    initrd   /live/initrd.img
    options  "root=/dev/sda4 rw add_efi_memmap"   

Restarting and booting from that new entry in rEFInd yields the error Invalid loader file. Error not found while loading. And it yanks me back to rEFInd loader. In the end I let rEFInd scan for new entries itself, it adds it correctly and I can boot GParted, but when I add the stanza manually it's not working. I want to know what was the mistake I made?

  • not having access to rEFInd myself, I'm tempted to ask: what differences are there between your own entry and the auto-populated one?
    – Fox
    Apr 17, 2021 at 17:11
  • Wanted to check that myself, buy rEFInd doesn't store it's auto detect config file anywhere. It runs autodetect on every boot. refind.conf contains only my own manual entries, not the auto detected ones.
    – math101
    Apr 17, 2021 at 17:31

1 Answer 1


According to https://gparted.org/livehd.php the options string should be quite a bit longer. Something like:

options  "boot=live config union=overlay username=user components noswap noeject vga=788 ip= net.ifnames=0 live-media-path=/live bootfrom=/dev/sda4 toram=filesystem.squashfs"

The error would seem to indicate that /live/vmlinuz is not found. Make sure that your /dev/sda4 filesystem contains a directory named live and that it contains files vmlinuz and initrd.img. If I understand correctly, there should also be a file named filesystem.squashfs in the same directory. The location of the filesystem.squashfs file is given in two pieces: the directory at the live-media-path= option, and the filename in the toram= option.

If the vmlinuz and initrd.img files are in some other location, make sure the pathnames on the loaderand initrd lines match the actual pathnames, relative to the root of the filesystem identified by the volume line. Likewise, if the filesystem.squashfs file is in a different location or named differently, adjust the options line to match reality.

As a wild guess, if GParted Live's Linux kernel starts up successfully, but fails to find the filesystem.squashfs file, you might try adjusting the bootfrom= part on the options line to bootfrom=LABEL=ARCH_202104. If GParted's kernel detects your disks in a different order, this might or might not help.

Because your filesystem type seems to be VFAT, it is supposedly case-insensitive... but rEFInd is using the UEFI firmware's filesystem support, and some UEFI firmware implementations are known to get the case-insensitiveness wrong. If you can see the auto-detected version, use the exact same character case as it does.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .