0

I'm trying to make an AP out of my Raspberry Pi and I have a strange problem.

I have installed hostadp and dnsmasq

When I set an open network everything works but when I try to add a passphrase, only one client connects (Huawei android phone). Other clients keep associating and dissociating and on the client side I get authentication error.

hostapd.conf looks like this:

ssid=Network
wpa=1
auth_algs=1
wpa_pairwise=TKIP
rsn_pairwise=CCMP
wpa_key_mgmt=WPA-PSK
wpa_passphrase=* some * passphrase *

I tried different values for wpa key and nothing works. dnsmasq is working, and for one client that can connect everything works fine.

Any ideas?

Thanks in advance!

1 Answer 1

0

The problem got resolved, but I'm not sure what was it...

Out of despair I changed my passphrase and everything started working.

My passphrase was something like

wpa_passphrase=* some * passphrase *

The first thing I did was to remove the white spaces and that's when it started working. However, when I put the white spaces back, it worked still.

If I add an extra white space after the passphrase, the passphrase of course changes and even the client that could connect in the beginning couldn't connect anymore.

If I add an extra white space somewhere around the passphrase line (like in the empty line above or below) the daemon cannot start.

Number of empty lines around does not change anything.

In short, I cannot reproduce the problem.

I'll leave it work for a couple of days and report if the problem reoccurs...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .