0

I'm currently facing an issue on my Dell Inspiron Laptop I am completely stumped on. It is running Arch Linux with Gnome. Yesterday the laptop hung during normal use, where I was unable to exit out of some GNOME window anymore and hard rebooted the laptop. When trying to restart it, I got the following message:

Starting version 248-2-arch
ERROR: device 'UUID=<uuid>' not found. Skipping fsck.
mount: /new_root: can't find UUID=<uuid>.
You are now being dropped into an emergency shell.
sh: can't access tty: job control turned off.

I then tried to access the system via live USB to see whether I could see the hard drive over that and perhaps chroot into it and fix the issue, but the drive won't even show up at all in fdisk, lsblk, lshw and the like. The drive is still visible in the BIOS, though, and passes Drive Self Tests, which I can do while in the BIOS. I am not very well versed in the inner workings of hard drives, mounting and stuff, so I have no idea what to do here. Any help would be very much appreciated!

4
  • There should be something about the drive or the interface to the drive in the kernel's startup messages. Use dmesg to view them, or journalctl -k. Apr 17, 2021 at 0:49
  • Of course, I don't know why I didn't check that before. This actually helped me find the issue.
    – xsimplex
    Apr 17, 2021 at 8:17
  • Add your finding as an answer. Apr 17, 2021 at 8:18
  • Just did. Thank you very much.
    – xsimplex
    Apr 17, 2021 at 8:44

1 Answer 1

1

After combing through dmesg I found the issue: For some reason, AHCI was disabled and RAID Mode turned on for all hard drives. Re-enabling AHCI mode solved the issue, but now I am wondering how on earth a hard reset could have triggered a flip on a Bios setting...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .