0

I connected two new sata hard drives to my ECS G31T-M9 motherboard. They are mechanical SATA III hdd's 500 GB and 1 TB respectively.

Issues started to happen with this 500 GB drive first, the motherboard eventually wouldn't detect it, so an immediate solution appeared by swapping the sata ports between drives, this solved the problem during an arbitrary time period, running fron one week to months, this problem sometimes appered after power surges but sure not the only cause.

Symptoms evolved rapidly affecting both drives and reaching to the point where one or both partitions were instantaneosuly unmounted by the OS without apparent reason and almost every mount attempt will be followed by an authomatical system unmount action.

Note to this is that the problem seems to only affect the sata drives as I also have an Ide drive connected and never seemed to have any problem.

The system running arch linux and all partitions contained ext4 file systems, so according to fsck this wasn't related to any errors inside the file systems because all error reports if any were unconsistent with this forced unmounts.

This reached to a point where all the sata hdds won't load on the bios no matter what I tried, this final issue risen all the red flags, so I disconected all the sata drives and connected them to a different motherboard, a biostar P4m89-m7b.

The biostar immediately recognized the drives so I spend some days backing up and recovering the data. I succesfully recovered all the files and nodes from the 500 GB drive but the partition was corrupted, the main superblock was missing and e/s errors were continuosly reported to system logs though luckly ddrescue only detected one error on the drive containing only 512 KB or so.

I momentanously suspended all the tests in this drive untill I check that indeed all my files are there and the 1 GB drive is still up for testing.

All that happened burnt out all my confidence on the first motherboard, the ecs one, but I'm still wandering what could have caused all this trouble.

Could it be that the PSU is failing? it's a generic 500W power supply and I attached to it just three hdd's and some external periferals, including speakers and printer.

BTW if it's related to the PSU why I had no troubles with the remaining ide hard drive?

It's a very intriguing mystery i search for answers so I preciate any comment.

Edit: this was the output in journalctl during unmounts blk_update_request: I/O error, dev sda, sector 15488728 op 0x0:(READ) flags 0x80700 phys_seg 8 prio class 0

Edit2: A quick inspection on the logs start reporting problems on 20 september (2020) at 16:56:59 on both drives simultaneously, logging starts on september 9, I'm horrible at following dates so I suppose that previous events from that date were trimmed and overwritten.

Complete log entries for both drives are the following:

Unrepeated log entries for both drives are the following:

Full events from september 20:

25
  • How many disk discontrollers are there? On older boards, you may still need to set the jumpers on the sata drives. Or remove the ide drive and see what happens - but I'm guessing the system is on the ide drive. Also, look at the output of "dmesg" on a clean boot with all the drives connected. If there's a power problem you should see something in dmesg - as well possible reasons why the sata drives are dropping off. Apr 16, 2021 at 20:51
  • I'm guessing the system is on the ide drive Right guess, you-re right. All that I remember were the continous E/S errors for both SATA drives. At the moment, all the SATA drives are unplugged until I'm able to store my files at a safer location. On monday or tuesday I will purchase a new hard drive to be this location and I can start testing on the failing drives. Apr 17, 2021 at 15:45
  • How many disk discontrollers are there? How can I tell? Which command lines I need to issue in order to this? Apr 17, 2021 at 15:47
  • this was the output in journalctl during unmounts blk_update_request: I/O error, dev sda, sector 15488728 op 0x0:(READ) flags 0x80700 phys_seg 8 prio class 0 Apr 17, 2021 at 15:59
  • I added the full logs at the body Apr 17, 2021 at 18:09

0

You must log in to answer this question.

Browse other questions tagged .