1

Bought an HPE Proliant Microserver Gen10 Plus and added a Kingston A2000 M.2 SSD drive with an adapter where I wanted to install the OS. A "regular" SATA disk was planned to hold my data.

Installation went just fine, but I didn't allocate all the disk when installing, so opened fdisk to add a partition from the remaining disk --> the start of my troubles.

I falsely tought the default parameters when adding the disk were good-to-go, but sadly they weren't and the partition table of the SSD was destroyed.

No worries thought I, start the install again, and lo-and-behold - hours of retrying the install.

  • Centos 8.2 gave the trusty "Pane is dead" error.
  • Centos 8.3 gave the new "Unknown error has occured" - with some extra info anaconda 33.16.3.26 dasbus

I tried the boot and minimum install ISO, I tried half a dozen boot options, to no avail. So where did this problem lie.

1 Answer 1

1

It seems that Anaconda does not like to scan disks with faulty partition tables. In my ignorance I thought "just let me start installing and I'll fix it", but since the installation would not even start that was a no-go.

I knew that the SSD might be the issue, so I removed it (in the end...) and re-started the install. And now the Install actually started.

So in with the SSD again and...

In the end I booted the ISO in rescue mode. Up with fdisk - create a partition and then - the crucial part - I added a file system to that partition and now the install finally started. I used mkfs.ext4 /dev/nvme0n1p1 - but I really don't think it matters what just that there was a "real" partition table there again.

Still Anaconda complained when I tried to manually partition the disk, so in the end I went with the Automatic partitioning - which went fine. Additional answer might perhaps shed light on what more to fix - but at least now my server is installed.

Hope this helps somebody down the road.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .