I'm been having issues with the scroll-wheel on my mouse for ages now. I've got a Silverstone Raven mouse, and the scrolling action is extremely jerky. If I scroll either up or down, at a natural speed, the scroll action will jerk in the wrong direction almost as much as it goes in the right direction.

I have to scroll almost twice as much to get where I want in a page, and often I'll lose track of where I am because it's not behaving as expected. If I deliberately scroll really slowly, it will go in the correct direction, as expected, but it's really painful.

So, to check that this isn't just a dodgy mouse, I rebooted into Windows - a rare occurrence for me these days - and tried it in there. Scrolling works beautifully; it's really smooth, no glitching, and is a pleasure to use.

Back in Linux-land, the scroll wheel is 'orrible.

In KDE System Settings, I have tried changing the number of lines the mouse wheel scrolls by, but this doesn't affect the glitchiness...

The mouse section of my /etc/X11/xorg.conf is as configured by default and looks like:-

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Anyone have any suggestions how to get my mouse working nicely? I'm on Linux 3.7.6 and this has been an issue for about two years now; I just haven't bothered to tell anyone 'til now..

  • I know you won't like this option but: I have a $5 no-name (literally -- there's not a word or symbol on it) usb optical mouse with scroll wheel and everything works great. I could not, in all honestly, tell the difference between this and some of the logitech things I paid 10-20 times as much for in the past. BTW if you have installed a driver in windows that came with the mouse, then there is your issue: the manufacturer has done something odd and not made it public or provided a driver for other platforms, complain to them. – goldilocks Feb 12 '13 at 14:36
  • Yes, you're right. This is a driver issue. Are there no settings I can hack at until it works properly, though? – Alex Leach Feb 12 '13 at 17:28
  • If it is that bad, I would think not -- something is not getting interpreted properly and it may be impossible to compensate for. That looks like a really nice mouse, but also pretty obscure. Sadly, even though manufacturers often make use of linux in their products (eg, Silverstone uses it with NAS devices), they still regard end-users of linux as corner cases that do not matter. I am sure they could just pay someone a few $1000 to write a low maintenance, open source linux driver that people could compile for themselves...industry politics I guess :( – goldilocks Feb 12 '13 at 19:21
  • I've reported the problem to Silverstone. Their engineers are all off celebrating Chinese New Year atm, so will get back to me afterwards. I pointed them at the source code and explained the problem in terms of Xorg events.. Found a decent review about the mouse yesterday, where they used xev on Linux to see all the detected events. They appeared to have no problems with the scroll wheel, though... – Alex Leach Feb 13 '13 at 13:04
  • yeah, +1 on driver issue. scroll wheels are jerky by the way they are built. Rolling the wheel sends a series of click-like events to X - it sounds like windows has some driver that is smoothing these events out – Jasen Feb 16 '13 at 6:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.