0

Normally I'm a Mac User, but now I installed a file server with Debian and OpenMediaVault. The Disks are set up as a ZFS pool. Everything works fine, just iTunes on Mac has a little problem with downloading new podcast episodes. iTunes first creates a temporary folder and only writes the file to the actual podcast folder at the end. But this temporary folder gets the permissions 675 and iTunes can't work with this. If I change the permissions very quickly to 777, the episode gets loaded.

It's not that iTunes has a general problem with the server. Starting with an empty drive, iTunes writes all needed libraries and folders with 755 and also copies music files correctly. It's only this temporary folder that gets the wrong permissions.

I tried all different versions I could imagine, even giving the user root status. It's always the same.

Is it possible to enforce 777 permissions when creating a folder, no matter who creates the folder? I read something about /etc/profile, but have no idea how to set that. Or is it possible to let the permissions be ignored? As I am the only user, that would not be a big problem.

This is the smb.conf:

load printers = no  
disable spoolss = yes  
printing = bsd  
printcap name = /dev/null  
unix extensions = yes  
wide links = no  
create mask = 0777  
directory mask = 0777  
use sendfile = yes  
aio read size = 16384  
aio write size = 16384  
time server = no  
wins support = no  
multicast dns register = no  
#Special configuration for Apple's Time Machine  
fruit:aapl = yes  
#======================= Share Definitions =======================  
[musik]  
path = /HansRAID/musik/  
guest ok = no  
guest only = no  
read only = no  
browseable = yes  
inherit acls = yes  
inherit permissions = no  
ea support = no  
store dos attributes = no  
vfs objects =  fruit streams_xattr  
printable = no  
create mask = 0664  
force create mode = 0664  
directory mask = 0775  
force directory mode = 0775  
hide special files = yes  
follow symlinks = yes  
hide dot files = yes  
valid users = "musik"  
invalid users =  
read list =  
write list = "musik"

ls -ld /HansRAID/musikgives this:

drwxrwsrwx+ 2 root users 2 Apr 14 22:31 /HansRAID/musik
2
  • 1
    Your question should be "what is enforcing permissions 675 to the temporary folder and how to fix it", because permissions 675 are very strange indeed.
    – telcoM
    Commented Apr 15, 2021 at 10:28
  • ls -ld /HansRAID/musik please (in your question). Commented Apr 16, 2021 at 8:21

1 Answer 1

2

Permissions 675 looks like there could be a mis-configured umask setting of 0102 (octal) = 66 (base-10) somewhere.

In some situations, umask values will require a 0 at the front to indicate that they are octal values: this might be a case of someone accidentally typing just "66" to an umask configuration field, instead of a proper octal value like 066.

The other way to enforce permissions would be to set a default ACL to a directory: any files and sub-directories would then get permissions according to the directory-specific default ACL instead of the session-wide umask value. The presence of an ACL on a directory or file is indicated by a + sign at the end of a permissions string in the ls -l listing, e.g. drwxr-xr-x+ would be a directory that has an ACL applied to it.

If the user writing the temporary files is the same as the user reading them (as would be the normal case), only the first digit (owner permissions) of the three-digit permissions value will matter. There should generally be no need to allow other users to write into any temporary files of your processes, but the creator of the temporary files (and only the creator) should have all applicable permissions.

So the "minimum required" permissions would be 0700 for temporary directories (folders), and 0600 for temporary files. These would correspond to umask 077. The "most relaxed practical" permissions would be 0755 for directories and 0644 for files. These would correspond to umask 022. Anything further than that would risk accidental or willful corruption of your temporary files by other users.

3
  • As I am a total newbie in Linux and the terminal, I didn't change any settings. If there is a mis-configuration, it must be from the installing. But I can't imagine that, coz all other folders, that iTunes creates, are correctly 755. Its only the temporary folders. So I have the suspicion that iTunes itself sets the wrong permissions. So, if there is a chance to overrule it, where and how can I do that?
    – Willi Wuff
    Commented Apr 15, 2021 at 14:32
  • That you would have found a pretty awkward bug in iTunes. It would mean that iTunes creates a temporary folder and effectively locks itself out of it. Since iTunes is not exactly new, and is probably much more widely used than OpenMediaVault, I would not bet on that. I'd begin by checking the Samba configuration of OpenMediaVault: it should be the /etc/samba/smb.conf file. I'd verify that all numeric permissions in there have the 0 prefix before doing anything else. If you can, please add your current configuration to your original question so people can see it instead of blindly guessing.
    – telcoM
    Commented Apr 15, 2021 at 14:50
  • I agree, that the bug is very doubtful, but the most user will use it with a Win or MacOS formatted disc and not with a Linux server. And on native discs its working fine. But I will check the smb config and add it here
    – Willi Wuff
    Commented Apr 15, 2021 at 15:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .