2

I have been using Windows 10 and Linux Mint for more than 2 years on the same computer. I always kept Windows up to date, but this time, the Windows update somehow overwrote grub to boot both OS. I can access Mint through the BIOS, but every time I start my computer, it automatically boots into Windows. I've tried a few things to get the grub back, but no success. Could anyone give me a solution of what I might be doing?

2
  • Lets see details, use ppa version with your live installer (2nd option) or any working install, not Boot-Repair ISO: Please copy & paste the pastebin link to the Boot-info summary report ( do not post report), do not run the auto fix till reviewed. help.ubuntu.com/community/Boot-Repair
    – oldfred
    Apr 15, 2021 at 2:27
  • You can visit my answer I recently answered a question unix.stackexchange.com/a/644829/449077
    – user449077
    Apr 15, 2021 at 6:05

1 Answer 1

0

After a long research, I managed to solve my problem. Below the step by step of the procedure I performed.

  1. I deactivated all boots that came before the Linux boot in the boot list, which is where GRUB is installed. With that, I deactivated the Windows boot, because it was one of those that came before Linux. For this, I used the command sequence below in the Linux command terminal.
sudo efibootmgr --bootnum 0002 --inactive
sudo efibootmgr --bootnum 0003 --inactive
sudo efibootmgr --bootnum 0004 --inactive

To check your boot sequence and IDs, use the following command:

sudo efibootmgr
  1. After that, restart your computer. Now the computer must boot the partition where GRUB is. If Linux starts but GRUB does not appear, appearing to be invisible, follow the procedure described by that answer to make GRUB visible.
2
  • Instead of deleting all entries, using efibootmgr -o 0003,0004,0001 would set the order as you like it. See the line BootOrder when executing efibootmgr.
    – FelixJN
    May 1, 2021 at 15:20
  • This is a good solution. However, I don't know why, I ran this command to change the order of entries, but it didn't work, it kept starting Windows. The command that I used does not delete the entries, they just make them inactive, they are still there. You can make them active again.
    – Luidi
    May 8, 2021 at 21:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .