0

I need to install earlier gcc than now. I already have gcc-10. I must install gcc-8 or gcc-6 in my computer then to build old project. I download the gcc-6 from github and tried install it as shown in this guide https://gist.github.com/slizzered/a9dc4e13cb1c7fffec53. I got the error: target not found: libart-lgpl . Google was show me than it's error occurs due to than this package is't contents from main repository. Stop! Ones again. If I want to build gcc-6 then I need to download and install yaourt then next install libart-lgpl which is not in the official repository? Pleas help my download & install some gcc compilers from my computer.

0

You should specify both gcc and gcc-libs. For example, if you want to downgrade from 7.1.1 to 6.3.1:

Method 1)

pacman -U /var/cache/pacman/pkg/gcc-6.3.1-2-x86_64.pkg.tar.xz /var/cache/pacman/pkg/gcc-libs-6.3.1-2-x86_64.pkg.tar.xz

Method 2)

downgrade gcc gcc-libs And select wanted versions.

Credit: https://stackoverflow.com/questions/34475253/archlinux-downgrade-gcc-from-5-2-to-4-8

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.