0

I have tried installing many linux but none works, most don't get past grub, some doesn't even get installed. Some stuck on black screen with blinking cursor after grub.

If anyone knows a fix or has tried installing then please do tell.

Distros I tried with -

  1. Linux Mint 20.1 Ulyssa - gets installed after doing grub edit quiet splash to nomodeset. After install booting too also requires to do so from elevated terminal. When it boots up, says not using GPU hardware, CPU usage would be more. When I update Nvidia GPU driver and restarts it gets stuck at black screen with blinking cursor after grub and I can't even open terminal from there, it just shows for a while then disappears again and cursor blinking comes again. Tried updating driver by downloading from Nvidia site. Tried running the .run file but it said same X server is running.

  2. Ubuntu 20.4 LTS - installs fine, boots up after making the required grub edit. But doesn't shutdown, suspend or log out and hangs a lot.

  3. Debian netinst/live/live-non free firmware - doesn't even get past grub menu, stuck on cursor blink screen even after grub edit.

  4. openSUSE - says couldn't open graphic install. reason memory less than 94MB or X server could not be started/stopped (don't remember exactly). If I proceed then fail at firs step only.

Any help would be appreciated.

3
1

I would suggest using pop os or use grauda linux those worked fine with my acer aspire 7 ( ryzen 5 5500U / Gtx 1650)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.