I have a pc with dual boot (Windows 8.1 + MX Linux), I'm using FreeFileSync as my backup apps, since the last few updates I did few months back, neither FreeFileSync nor GSmartControl worked with Silicon Power drive (I tried a month back a new backup, it failed on my SP 1TB external drive), previously GSmartControl could recognize SP drive, but now it won't see it, and when tried to do backup, got errors (G_IO_ERROR_FAILED: Trash portal failed on /media/michael/SP PHD U2/data/media/ebook/fiction/best seller/conto English1.epub [g_file_trash]), tried to delete the file manually (either through terminal or Thunar), got Input/output error (even using sudo). Tried to use the following commands (sudo rm -f cont* & lsattr conto*), both failed. rm did not return any message, but the file is still there, see the output below

$ sudo rm -f conto*
michael@mx:/media/michael/SP PHD U2/data/media/ebook/fiction/best seller
$ ls
'conto English1.epub'

and lsattr gave the following error

lsattr: Invalid argument While reading flags on conto English1.epub

Found a solution similar to mine on this post, I've never worked with VirtualBox in Linux, better ask before doing something stupid, I'd like to make sure that this will solve my problem. ps: my Windows in dual boot is corrupted, so I can't boot to Windows.

  • This could be down to 1) disk corruption 2) fs corruption 3) malfunctioning ntfs-3g driver Apr 11, 2021 at 19:07
  • @ArtemS.Tashkinov, sorry forgot to mention that the drive must be OK, because even the delete command gave error, I can still open the file using Foliate, so I assume my file must be OK, it seems more likely malfunctioning of ntfs-3g driver, how do I fix it?
    – michaelbr
    Apr 12, 2021 at 9:00


You must log in to answer this question.

Browse other questions tagged .