0

I’ve had a bit of a hunt around, and tried LOTS of things for the following problem. I feel like I’m near the end of it.

I run Ubuntu Studio 18.04 on a few PCs, with LVM. I pulled the Hard Drive from an old 32 bit based machine, and I am trying to mount it as an external drive via USB to another PC - Ubuntu 18.04, 64 Bit.

I just want to read the contents and copy files and folders to the new PC and another external backup HDD.

In Windows and Macs, pulling an OS disk and plugging it into another PC via USB -- normally reads and mounts the disk straight away, and I am able to go ahead and copy / read write files.

On Linux / Ubuntu Studio - after reading several articles,
and trial and error, here is where I am up to :

I have installed some kind of “LVM2” drivers (I think) - I believe I used :

sudo apt-get install lvm2

I have read this article

https://ixnfo.com/en/solving-the-error-mount-unknown-filesystem-type-lvm2_member.html

Which, among another couple of articles, pointed me to use lvdisplay to get the name of the LVM.

As my logical volumes have the same name - (My PC and Ext HDD / former PC which both ran ubuntu studio)

These are the lvdisplay outputs - (removing all the other unnecessary info and swap partitions from lvdisplay output - and I have obviously changed the name of the UUIDs)

  --- Logical volume ---

  LV Path                /dev/ubuntu-studio-vg/root

  VG Name                ubuntu-studio-vg

  LV Size                464.80 GiB

  LV UUID                1234abc-1234-abc

  --- Logical volume ---

  LV Path                /dev/ubuntu-studio-vg/root

  VG Name                ubuntu-studio-vg

  LV Size                <930.37 GiB

  LV UUID                789xyz-789xyz-789xyz

I then try the info in this article

how to mount by UUID without using /etc/fstab

Using Thomas’s answers near the top as follows :

From the manpage of mount. -U, --uuid uuid

Mount the partition that has the specified uuid.

So your mount command should look like as follows.

mount -U 1234-SOME-UUID /some/mount/folder

or mount --uuid 1234-SOME-UUID /some/mount/folder

A third possibility would be mount UUID=1234-SOME-UUID /some/mount/folder

I have tried the one with the syntax in bold

mount -U 1234-SOME-UUID /some/mount/folder

It doesn’t work. I get :

mount: /media: can't find UUID=1234-SOME-UUID

Now, I feel a bit stuck.

I seek help from the wizards.

Help! (:

Thanks so much for any answers.

Additional data:

:~$ lsblk -f 
NAME FSTYPE LABEL UUID MOUNTPOINT
sda 
└─sda1 LVM2_member Lmc6Lt-lBPY-Xdwg-mjLb-lf0B-########      
   ├─ubuntu--studio--vg-root ext4 6e198faf-7911-4ce4-8008-######## 
   └─ubuntu--studio--vg-swap_1 swap 877d70a6-8422-4c2d-bb99-######## 
:~$ sudo mount -U leUvLc-DuXM-vvcl-vBPr-2thG-####### /media 
mount: /media: unknown filesystem type 'LVM2_member'. 
:~$ blkid /dev/sdb1
UUID="leUvLc-DuXM-vvcl-vBPr-2thG-#######"  TYPE="LVM2_member" PARTUUID="8f065194-01" 
:~$ sudo mount -U leUvLc-DuXM-vvcl-vBPr-2thG-####### /media 
mount: /media: unknown filesystem type 'LVM2_member'.
13
  • The disk doesn't have that UUID. I suspect the filesystem is not recognized. Use lsblk -f or blkid to list all storage UUIDs that your computer is aware of. Feel free to add the output to the question if you need more help. Commented Apr 10, 2021 at 8:46
  • Thanks very much for your help berndbausch . Unfortunately I seem to be in the same position. Here is the outputs -- I tried mounting the UUID they both output -- all outputs and inputs tried are as follows -- I have modified the last digits of my UUIDs though - EDIT -- I don't know how to post it all with the char limit of this post, I'll edit it and post in following comments.
    – spaz
    Commented Apr 11, 2021 at 4:32
  • :~$ lsblk -f NAME FSTYPE LABEL UUID MOUNTPOINT sda └─sda1 LVM2_member Lmc6Lt-lBPY-Xdwg-mjLb-lf0B-######## ├─ubuntu--studio--vg-root ext4 6e198faf-7911-4ce4-8008-######## └─ubuntu--studio--vg-swap_1 swap 877d70a6-8422-4c2d-bb99-######## :~$ sudo mount -U leUvLc-DuXM-vvcl-vBPr-2thG-####### /media mount: /media: unknown filesystem type 'LVM2_member'.
    – spaz
    Commented Apr 11, 2021 at 4:35
  • :~$ blkid /dev/sdb1: UUID="leUvLc-DuXM-vvcl-vBPr-2thG-#######" TYPE="LVM2_member" PARTUUID="8f065194-01" :~$ sudo mount -U leUvLc-DuXM-vvcl-vBPr-2thG-####### /media mount: /media: unknown filesystem type 'LVM2_member'.
    – spaz
    Commented Apr 11, 2021 at 4:36
  • 1
    I am a bit surprised that lsblk doesn't discover sdb. In any case, sdb1 is formatted as a physical volume, which you are trying to mount. This doesn't work. You need to mount filesystems. However, the volume group that sdb1 was a member of is not recognized. Can you perform the pvscan /dev/sdb1 and pvs commands to see what is on that physical volume? Commented Apr 11, 2021 at 11:20

1 Answer 1

0

I had a similar issue with disks being moved to a server with the same VG and LV names. I also tried to manually mount via command line and got the same error:

"mount: /media: can't find UUID=1234-SOME-UUID"

I was able to look inside the disk with the pvdisplay "-m" flag and confirm we were able to see the LVs, names were intact:

pvdisplay /dev/xvdf -m

Give this a try. I start off by looking to see if the FSTYPE shows in lsblk:

lsblk -f

Get UUIDs of the VGs:

pvs -o +vg_uuid

Rename the VG by using the UUID from above command (since both have the same vgname).

vgrename <UUID> <NewVGname>

Check/make sure the LVs are showing ACTIVE in lvscan. If they're not, run:

modprobe dm-mod
vgchange -ay

They should now be ACTIVE and mountable:

lvscan
mount /dev/mapper/newname /mnt/mntpoint
lsblk -f

You can now edit /etc/fstab to make the mounts persist through reboots.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .