0

I'm using Kali Linux and I'm getting the error

dpkg: dependency problems prevent configuration of messengerfordesktop: messengerfordesktop depends on libappindicator1 | libappindicator | libappindicator-gtk3

while writing this:

sudo dpkg -i messengerfordesktop-2.0.9-linux-amd64.deb

I tried sudo apt-get install -f but it says the package messengerfordesktop will be removed. I have tried installing these 3 packages manually as well but I'm getting this error:

E: Package 'libappindicator1' has no installation candidate
E: Package 'libappindicator' has no installation candidate
E: Package 'libappindicator-gtk3' has no installation candidate

So what should I do?

3
  • Have you considered Debian or other distro more suited to beginners? Apr 11, 2021 at 10:59
  • I don’t think Debian is for beginners, but I've been using Linux for a long time and, in principle, I'm already quite familiar with different distributions.
    – Albert
    Apr 11, 2021 at 16:46
  • Debian is fine. But I used it in the example to make a point (Debian is often considered a difficult distro. I don't know why (mostly historical). Apr 11, 2021 at 18:16

2 Answers 2

1

I searched on internet little bit. I found some answer for you. I don't know if they are helpful.

  1. Installing Facebook Messenger

  2. Facebook Messenger Linux

  3. How to install messenger in linux

  4. Facebook Messenger

enter image description here

I found messenger-collabee. I am not sure what it is. It may be facebook messenger also. I am not sure.

Install complete python tools

apt-get install python-setuptools python3-setuptools python-qt4-phonon python-qt4-phonon python3-pyqt4.phonon

You don't have to run above code cause, Kali has python.

Run it

wget https://github.com/oconnor663/linuxmessenger/archive/master.zip

cd linuxmessenger-master/
chmod +x fbmessenger
./fbmessenger

For you issue try by updating

sudo apt-get update
sudo apt-get upgrade
3
  • Thanks for answer. But as I learned on Kali it cannot be done without snap.
    – Albert
    Apr 9, 2021 at 21:13
  • Albert Yeah! Kali doesn't have snapd by default. That's why we have to install it.. I saw @GAD3R's answer... I think his answer is correct that's why I will tell you to mark that as an answer.. As you are new to Unix SE that's why I am giving you a picture how to mark as an answer. i.stack.imgur.com/RECp8.png
    – user449077
    Apr 10, 2021 at 3:56
  • 1
    Thanks for picture, but I know that, I'm already quite familiar with stackoverflow😅
    – Albert
    Apr 10, 2021 at 8:58
0

libappindicator-gtk3 isn't available in Kali Linux. libappindicator1 and libappindicator have been removed from Kali repositories.

You can install Messenger from snapcraft:

sudo apt install snapd
sudo snap install core
sudo snap install messenger-collabee
sudo snap install slack --classic
sudo snap install discord

If you are using an old version of Kali (less than 2021.1) then you have to run program this way:

snap run <application>
4
  • Thanks for answer. I didn't know that that package isn't available in Kali Linux. I also wanted to install Discord and Slack, but they have those dependencies too.
    – Albert
    Apr 9, 2021 at 21:12
  • 1
    @Albert snap install discord and snap install slack... If you want to search any package then,,, search this way snap search <package name>
    – user449077
    Apr 10, 2021 at 3:59
  • @Albert See my edit. Please.
    – GAD3R
    Apr 10, 2021 at 7:18
  • @GAD3R In kali(only new version 2021.1) we get desktop entry when we install from snapd...!
    – user449077
    Apr 10, 2021 at 7:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .