14

I get the error while running a script which tries to send emails.

send-mail: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
send-mail: warning: inet_protocols: configuring for IPv4 support only
postdrop: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
postdrop: warning: inet_protocols: configuring for IPv4 support only

Could anyone say what is the issue, do I require some permission?

9

You don't have IPv6 configured in your OS's network stack, but your mailer (presumably postfix) is configured to use IPv6. Since there is no IPv6 for your mailer to use, it's warning you that it's only going to use IPv4. From the postfix readme:

if you see error messages like the following, then you're running Linux and need to turn on IPv6 in the kernel: see http://www.ipv6.org/ for hints and tips. Unlike other systems, Linux does not have a combined stack for IPv4 and IPv6, and IPv6 protocol support is not loaded by default.

postconf: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
postconf: warning: inet_protocols: configuring for IPv4 support only
44

To disable the messsage, go to /etc/postfix/main.cf and change from:

inet_protocols = all

to:

inet_protocols = ipv4

This will only use ipv4 and the warning message will go away.

You will have to issue a stop and start for postfix to register the change. A simple reload will yield:

mail postfix/master[8330]: reload -- version 2.9.6, configuration /etc/postfix mail postfix/master[8330]: warning: ignoring inet_protocols parameter value change mail postfix/master[8330]: warning: old value: "all", new value: "ipv4" mail postfix/master[8330]: warning: to change inet_protocols, stop and start Postfix

  • 5
    stackexchange is better than the manual, because I can get answers like this in an instant, without having to wade through long-winded textbook chapters on the implementation decisions that went into raspbian linux kernel builds. – Greg Gauthier Dec 23 '14 at 18:22
  • so mark this as the right answer then ;) – silpol Mar 30 '16 at 16:07
  • This only masks the underlying problem, which is that someone disabled IPv6 on the system. The underlying problem should be fixed instead. – Michael Hampton Sep 25 '18 at 13:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.