1

I have a supermicro server that has worked fine for however long, and monthly do yum update on it and it is currently at RHEL 7.9 3.10.0-1160.15.2.el7.x86_64. It is one Nvidia K620 graphics card having one white DVI output port, in addition to the mainboard blue vga port.

Using a 24" 1920x1200 monitor off the mainboard blue VGA port, everything linux in basic black & white text displays on it up until runlevel 5, and in runlevel 3 I get a text based login screen on VGA monitor. When going to runlevel 5 (i.e. graphical.target) the vga mode on the monitor goes blank and then I switch the monitor to DVI mode and then get the gnome graphical login display coming from the k620 graphics card. This is how it has worked and I was happy with it.

After updating to NVIDIA-Linux-x86_64-460.32.03.run I am stuck with only the text login (runlevel 3) on VGA monitor. When I try to go to graphical.target and put the monitor to DVI I get a black screen If I remote in over the network via VNC the gnome desktop and everything still works.

Additionally, a similar server having only a blue mainboard VGA but having an Nvidia P100 gpgu (no graphics output) worked where the runlevel 5 graphical console displayed to the VGA console monitor. But now after an nvidia [cuda] update I no longer have a graphical console there either and am stuck with basic text console.

I believe this to be a RHEL linux and/or gnome display manager problem, and not necessarily nvidia; I am looking for insight as to what is happening and how to regain my runlevel 5 graphical login console. All I ever knew of was nvidia-xconfig and that worked on the file /etc/X11/xorg.conf and prior to my problems with everything working just fine in RHEL 7.9 there actually was no xorg.conf file present; so I know I am about completely ignorant as to how graphics works now in rhel 7.9. please help. How does one fix gdm, what if anything related to gdm can I try?

1
  • 1
    Please post the output of /var/log/Xorg.0.log to e.g. pastebin.com Apr 7, 2021 at 21:04

1 Answer 1

0

I found the answer to this stated in https://access.redhat.com/solutions/421683

The redhat solution only mentioned mesa-libGL For reference this is what I did that was successful:

  • unblacklist nouveau in /etc/default/grub followed by grub2-mkconfig -o /boot/efi/EFI/redhat/grub.cfg
  • rpm -ev --nodeps mesa-libGLES mesa-libGLU mesa-libGL-devel mesa-dri-drivers mesa-libEGL-devel mesa-libEGL mesa-libxatracker mesa-libgbm mesa-libGLU-devel mesa-filesystem mesa-libOSMesa mesa-khr-devel mesa-libglapi mesa-libGLw mesa-libGL
  • yum install mesa* xorg-x11-drv-nouveau
  • dracut -vf
  • yum history sync to remove yum altered outside warning.
  • if using dkms do dkms status and be sure it responds empty regarding nvidia.
  • reboot
  • console graphics restored, as had been prior to installing nvidia or cuda.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .