1

I was trying to 'burn' a ISO to my usb flash drive using the good ol'

dd if=some-linux-distro.iso of=/dev/sdb bs=4M && sync

but the process took a long time. So, I looked at the process in HTOP and the status of the process was D which the manual page says means disk sleep (uninterruptible). I thought that maybe there is something wrong with my dd so, I tried copying the ISO file using Caja to the USB drive to burn in on another machine. The copying starts but then the copy speed starts to decline slowly until the copy process comes to a halt (I guess, it was being copied to the cache, instead of the disk.)

I tried another USB, same thing. Also, another machine can also write to the USB drive. So, I guess its not the USB drive at error. I even rebooted my computer (lost my bragging rights on uptime) but still get the disk sleep(uninterruptible) when I try writing something.

Please send help. Thank you.

4
  • Are there any I/O error messages in the dmesg listing?
    – telcoM
    Commented Apr 7, 2021 at 6:06
  • I just noticed that the copy/write goes smoothly till it reaches 3.2 GiB after which it steadily falls to zero.
    – sigsegv
    Commented Apr 7, 2021 at 6:06
  • @telcoM The only thing that looks like an error in dmesg is this: [sdb] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
    – sigsegv
    Commented Apr 7, 2021 at 6:11
  • That's just an informative message about the state of the caching specific to that particular device. So either the USB drive itself does not have a write cache of its own, or it's disabled by default (which would be a sensible default as it would be another way to accidentally lose data in a hot-unplug situation).
    – telcoM
    Commented Apr 7, 2021 at 6:46

1 Answer 1

0

Same situation as OP although no idea why I'm only seeing it now as I've been dd'ing isos to usbs for years without any problems...maybe caching changed recently.

Anyway, it seems dd reports data written to cache as data written and caches are used even where the device has no caching enabled. The result is it still has a long way to run when it reports all data written.

If you leave it long enough it should eventually finish.

To see the real progress use the flags here and it won't look like it has hung.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .