0

I'm running windows 10 inside gnome boxes (on fedora) which, while kinda slow, works well enough.

However, after closing and reopening boxes, it appears that windows just continues where I left off. Now, of course that's what it should do, but it also keeps the time and date from where I left it and when I'm not connected to the internet, it can't grab the correct time from network.

Now, I can either set the correct time by hand, or always "correctly" shutdown and boot windows to fix it, but I was wondering if there's a way to provide a time server for windows/boxes guests inside the virtual network that boxes is running.

Reason I'm asking: I need windows for some software to read data from meteorological stations, so I'm in the sticks, not connected to the internet and this software apparently depends on correct system time to be able to download data. If my windows thinks it's one week ago, I can only download data from one week ago.

3
  • Of course you can create a time server. Since this is Fedora, I think Chrony is the tool of choice. But you can simply direct the Windows guest to one of the public time servers on the internet. Now, I don't know how the NTP client on Windows behaves and how it can be configured; perhaps you should ask the question in a forum that helps with Windows problems, such as superuser.com. Apr 6, 2021 at 15:17
  • NTP is not an option, since I'm completely offline when I'm running my VM. I'll check out Chrony, but for now, setting time manually in windows is the workaround.
    – JC_CL
    Apr 13, 2021 at 6:08
  • While you seem to have solved your problem, you can run a time server on the host that serves the host's time to the guest. No need for internet access. Apr 13, 2021 at 9:00

2 Answers 2

1

I just found this which seems like your problem. https://gitlab.gnome.org/GNOME/gnome-boxes/-/issues/434

Personally, I have had problems with Gnome boxes as well. Is there any way you can test this on Virtualbox? The problem that the link talks about is an underlining problem with QEMU.

1
  • 1
    Thanks, this appears to be the issue I've run into. Can't test it on VBox right now. Guess I have to put the time settings for Windows on Autostart or just leave them open when I'm freezing it, so that I remember to do it, first thing I start the VM.
    – JC_CL
    Apr 13, 2021 at 6:05
0

I had the same issue with a:

  • Guest VM Windows 10 Professional
  • Host Fedora 34

I ended up having to query a few things on my host Linux machine


Host enquiries

  1. work out which NTP server my host was getting its time from using

ntpstat

this returned an IP address.

I reversed looked up that to get a DNS name using

dig -x +noall +answer

Once I got my reference "Time Server" DNS name, I moved onto the Windows guest VM


Windows Guest VM Config

This required four config steps:

  1. Make sure the Windows Time service is stopped before performing this.

  2. Under Windows "Date & Time" settings, under "Add clocks for different time zones" and then "Internet Time > Change Settings", change the time "server" to be the DNS name you looked up earlier.

  3. Go to the Windows Firewall and ensure that port 123 is opened for incoming and outgoing connections.

  4. Re-enable the Windows time service.

After doing this, my Windows guest managed to sync its time with the same NTP server that my host is using.

At the time of writing this, I haven't checked if the automated syncing is working though, but I don't see why it wouldn't.

What I noticed though, is that my VM looses minutes here and there, so I will have a look to see if I can increase the 'sync' frequency, which is currently set to be daily only.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.