I have a weird problem lately:

My system only boots if either a CD is inserted (any CD, not a specific CD(*)) or if I enter UEFI-BIOS before boot.

Otherwise, grub2 would start but afterwards the screen stays black.

The last thing I did before this problem occured (at least I think this was the last thing) was adding partitions on /dev/sdb and /dev/sdc, generating a raid-1 out of these two partitions and adding the RAID to /etc/mdadm/mdadm.conf and /etc/fstab.

My boot-device however is /dev/sda (I have a EFI-partition on /dev/sda1)

If that helps: I run Debian Wheezy (but also have some packages from experimental).

How can I locate the error and solve it?

(*) I tried the following CDs:

  1. A Debian Wheezy Live DVD (actually a DVD, not a CD) => System booted
  2. A Mini CD which came with my WiFi-Router (so to say a driver CD) => System booted
  3. Another driver CD that came with my printer ages ago => System booted
  4. A music CD (Vive la Fête - République Populaire, but I'm quite convinced that doesn't matter) => System didn't boot

It looks like all data CDs work...


here's my dmesg file (with inserted CD)
maybe that helps!?

  • 1
    What is "any CD"? Even a music CD, only a bootable CD, CDs with data? – vonbrand Feb 11 '13 at 1:58
  • After power on, do you have an option F12 Boot Menu (or another F-Key)? Does it boot from that menu? – ott-- Feb 11 '13 at 12:13
  • @ott-- no, I can press DEL or some F-button (I think it is F12), which both brings me to the first page of UEFI-BIOS, where I can choose the boot order (but I'm not exactly sure, I will have a look when I'm home again). – Marcel Feb 11 '13 at 12:32
  • added a pastebin of dmesg – Marcel Feb 11 '13 at 18:35
  • @ott-- I just checked - I have no boot menu "outside" of UEFI-BIOS. When my computer starts (the mainboard is an ASUS P8H77-I) I can enter the BIOS with DEL and F2 Is there a logfile I can check for the cause of the error? – Marcel Feb 11 '13 at 19:28

I have "solved"??? the problem.

Well I don't really have a solution, as I couldn't identify the reason for the problem. However, the last 2 boots went well without a CD inserted and without entering the BIOS.

What I did was the following:

  1. I installed the package firmware-realtek as dmesg -T -l err,crit,alert,emerg showed me that the realtek firmware was missing.
  2. I updated my system with

    aptitude update
    aptitude upgrade
    aptitude dist-upgrade

Now it seems like the problem is gone...

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.