0

I am trying to install a program called aeskulap dicom image viewer in Void Linux. This Void Linux desktop installation is otherwise working very well. Aeskulap program is not present in Void Linux repositories (current, multilib, nonfree, multilib-nonfree). Hence, I am trying to install its exe setup file with wine. However, I am getting following error:

$ wine aeskulap-0.2.1-setup.exe
002c:err:winediag:WS_getaddrinfo Failed to resolve your host name IP
Application could not be started, or no application associated with the specified file.
ShellExecuteEx failed: File not found.

Same error comes if I use wine64 instead of wine

I found some links for this error (e.g. this) but could not understand how to correct it.

Where is the problem and how can it be solved? Thanks for your help.

Edit: Wine runs notepad.exe, though there is an error output:

$ wine notepad.exe
002c:err:winediag:WS_getaddrinfo Failed to resolve your host name IP
0
0

The title of the question makes it sound like all Wine applications do not work - is this really the case? Or it's only about this particular app?

Well, Wine doesn't promise 100% Windows compatibility and lots of Windows applications don't work in it. Search the internet for solutions, particularly at websites like https://appdb.winehq.org and https://bugs.winehq.org Lastly what's your wine version? It always makes sense to try the latest release which is 6.5 at the moment.

If you've found nothing, you're running the latest version of Wine, other applications work under Wine and the application that you're running can be downloaded legally, you may want to post a bug report at https://bugs.winehq.org/

3
  • I have added output of command: wine notepad.exe. Can I try any steps to make wine run this executable? – rnso Apr 5 at 18:15
  • I have changed the title to show that the question is only about this file not running, rather than wine not working with any file. – rnso Apr 5 at 18:45
  • The error is not fatal since notepad runs which means Wine doesn't quite work for this particular Windows application. Again, look for solutions on appdb and bugzilla – Artem S. Tashkinov Apr 5 at 19:29
0

The problem was due to running 32-bit exe applications on a 64bit system without using WINEPREFIX. The problem got sorted out after using instructions on this page. Main command is to create and use a new 32-bit wine prefix:

WINEPREFIX=~/.new32prefix WINEARCH="win32" winecfg

Now wine works well and creates a wine submenu also in xfce4 application menu. The installed program is found in xfce4 application finder also. It places a program shortcut with proper icon on desktop as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.