0

This is a weird problem that i'm having, so i love xterm i've been using it for over a decade, and I've never had any problems with it. I was using it xterm fine under debian / gentoo / solaris / hp ux, i recently upgraded this system, with a AMD Ryzen 5 board, and removed the old Intel board. I completely reinstalled the operating system, the graphics card, window manager and operating system version are the same (i.e. still debian)

But whenever i switch workspaces (I'm using windowmaker) Xterm takes several seconds to redraw the xterm contents, and i use dozens of xterm windows, so it can take about 5-6 seconds to redraw all the xterm contents on the screen. I've never had this problem before, it must be some setting.

Is there some way to force it to remember the xterm contents so it doesn't redraw the entire thing unnecessarily each time you change workspaces?

I've tried other terminals too, and those also redraw the entire terminal contents from start to finish. Very slowly. So I don't think this is an xterm problem, think it's some linux xorg setting. Has anyone else come across this?

Just to add something to this, i notice the screen refresh goes really slow for the top half of the screen, then instant for the bottom half. It's almost as though it's forgotten than the terminal is maximised. When I press ALT+ENTER to full screen the window, the screen redraws instantly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.