I am running Linux Mint on my sister's computer. Everything was working fine, but then one day she turned it on and she got a strange message she didn't understand. I think it was some kind of question in terminal. Unfortunately my sister, despite her natural intelligence, didn't know what to do and decided to simple turned the computer off. Since then, everything goes wrong.

The problem

When booting I got classic Linux Mint splash screen, when pressing ESC I get this:

The message on third row and later mean:

/dev/sda5 clean, 182625/1602496 files, 1140445/6401536 blocks
/dev/sda6 clean, 20551/10928128 files, 14921843/43686912 blocks
Partition for /home is not ready or present.
Continue waiting or press S for skipping the mounting or M for manual mount.

Pressing neither of those buttons work. It is simply stuck and does nothing.

Attempt 1 - recovery mode

So I've realized I am having problem with /dev/sda5 or /dev/sda6. I booted into recovery mode. I tried to check for consistency of packages and I got:

Again the same message, only one more:

/dev/sda6: the journal is renewing

Again nothing happens. Choosing different operation in recovery mode menu leads to the same thing.

Attempt 2 - gparted

I've downloaded a live cd with gparted to check out the disks. In gparted I've checked the disks, no errors. Hm. I mounted the both /dev/sda6 and /dev/sda5 in terminal, which worked. I was able to see all data unharmed.

Attempt 3 - getting rid of /home

Because everything has been about the bloody /dev/sda6 which is automatically mounted to /home I've decided to remove it from /etc/fstab and leave only the system disk /dev/sda5. It was easy hence I was in gparted already. I rebooted and nothing happened. Not even splash screen, no message, no sound from computer at all. It was running, but doing nothing. Uff. EDIT: I am still able to get past grub. This nothing happens AFTER choosing Linux Mint in grub.

Attempt 4 - reinstall?

Since I have the /home on separate partition I was wondering I could simply reinstall the system. I've downloaded ISO, put it on USB, and I was astonished to get another terminal like text and freeze:

Attempt 5 - Stack Exchange

You are on, guys.

Final notes

I have the feeling all this leads to hardware problems, but a) I've successfully mounted both partitions and b) I have windows 7 on another partition (but same disk) that works. I guess formatting the disk using gparted and install Linux Mint again would work, however I would prefer saving all the data (I would have to back up everything). Any help how to debug or fix this problem will be much appreciated.


fdisk -l https://dl.dropbox.com/u/71390144/keepers/fdiskl

fsck -n /dev/sda6 https://dl.dropbox.com/u/71390144/keepers/fsck6

cat /etc/fstab https://dl.dropbox.com/u/71390144/keepers/fstab

smartctl -a /dev/sda https://dl.dropbox.com/u/71390144/keepers/smartctl

  • Is the fstab correct? I mean is it mounting /dev/sda6 as home ? – terdon Feb 10 '13 at 18:31
  • Please post the content of /etc/fstab and the output of fdisk -l (from the GParted livecd). Also run smartctl -a /dev/sda and post the output. Run fsck -n /dev/sda6, are there errors? – Gilles 'SO- stop being evil' Feb 10 '13 at 19:35
  • Thx, please see the attached files in the original post. – tsusanka Feb 10 '13 at 20:28

I fear you destroyed most of the system by now, your only solution is to reinstall. But by the amount of problems you have, I'd run a memory test (memtest, probably an option on your installation media, leave it running a few hours), and run some disk diagnostics (the disk might be shot, that could explain some of the symptoms like failing mount and fsck hanging).

My condolences.

  • I've run the memory test for a while and it was okay. What "disk diagnostics" do u recommend? – tsusanka Feb 10 '13 at 20:29
  • Check if the vendor of the drive has something available. Google for "disk diagnostics", that gives a lot of hits. – vonbrand Feb 11 '13 at 3:15

It's hard to say how much I can concider this as an answer, but it is a solution. I finally decided to give a try to 32bit installation ISO, which miraclously worked. I installed the system and everything works fine. When I tried again (after the install) the 64bit ISO could be loaded. I have no idea why what so ever.

Anyway, if you experience any trouble similiar to this, just try to use 32bit installation ISO.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.