I just bought a new motherboard which has BIOS and UEFI. I have a previously working LiveCD installed on my usb, created with LiveUSB Creator. I tried using it to boot but got stuck at the grub command line. Next, I followed the instructions here to create a new LiveCD using livecd-iso-to-disk command line method with the following options --format --reset-mbr --efi --overlay-size-mb 600. I did the install on the second partition of my usb stick with 2GB allocated to this. Then I check that the partition is indeed bootable using parted. However, the boot process was again halted at grub with the following errors:

error: file `/isolinux/vmlinuz0' not found.
error: you need to load the kernel first.

Is this my problem or the motherboard problem? How do I go about solving it?


This appears to be a file/folder naming issue with some motherboards not able to find the kernel. I did the following renaming:

/syslinux to /isolinux
/isolinux/syslinux.cfg to /isolinux/isolinux.cfg

I manage to get the kernel to load. But it got stuck at dracut, this time with the following warnings:

dracut-initqueue[229]: Warning: Could not boot.
dracut-initqueue[229]: Warning: /dev/disk/by-label/Fedora-18-x86_64-Live-Desktop.is does not exist
dracut-initqueue[229]: Warning: /dev/mapper/live-rw does not exist

I am wondering if this is again a naming issue. Why is it looking for .is instead of .iso? Anyone has any idea? Thanks.

  • Re update: Nothing whatsoever to do with your motherboard. That one just locates a boot sector to load and run, and that takes over completely. I can't believe the official media from Fedora could be this broken, I guess you are just getting some leftovers from your first partition or the hard disk because the boot isn't going as you think. – vonbrand Feb 11 '13 at 4:18
  • @vonbrand, I have reformatted the flash drive, making it the first and only partition and also removed the overlay. Should have update that. – Question Overflow Feb 11 '13 at 4:23
  • @Question Overflow did you try liveusb-creator with Fedora 17 or Fedora 16? I am having problems with Fedora 18 ISO image, too. But only with persistant storage. – erik Feb 11 '13 at 7:25
  • @erik, I did managed to install both Fedora 17 and 18 on older motherboards using the liveusb-creator. Can't do it on the newer dual EFI-BIOS type even using Legacy option. Now have to forgo the persistent storage and partitioning in order to install Fedora 18 using livecd-iso-to-disk method to get it to work. – Question Overflow Feb 12 '13 at 6:48
  • 1
    @HoàngLong, actually I missed out the second (installation) step in the two-stage setup process with livecd-iso-to-disk causing it not to be installed on my USB drive and leading to all the warnings. If I remember correctly, there is a 'yes' or 'no' question at the end of the first (verification) step. You might have chosen the cancel option after the first step because the notification reads like something wrong had happened. Not sure if this is applicable to you though. – Question Overflow Mar 13 '13 at 14:34

Fedora also recommends using liveusb-creator. I'm not sure you can install with livecd-iso-to-disk to the second partition of an USB stick, and 2GiB is definitely not enough for a 4GiB DVD image.

Are you using BIOS or UEFI? UEFI is still in flux, I wouldn't count on it working everywhere.

  • 1
    Surely the Fedora-18-i686-Live-Desktop.iso was used. This is only 932184064 Bytes aka 933 MB in size. – erik Feb 10 '13 at 19:13
  • @erik is right. The .iso file is much lesser than 4GB. I tried both methods and both UEFI and BIOS. Now got stuck at dracut. Have updated my question. – Question Overflow Feb 11 '13 at 4:07

This is common, weird bug - installer images have incorrect labels set for root fs. Use "blkid" after falling into emergency shell to determine installer image LABEL. Reboot. Press "TAB" at Grub boot screen and edit label for root fs.

For Fedora 18 x86_64 netinst image LABEL in grub was set to "Fedora%2018%20x86_64", changed it to "Fedora%2018%20x", because root fs label was "Fedora 18 x" :)

Note, that you will have this problem with both fedora live usb creator, unetbootin, etc - it's independent.

  • Have you reported it? – vonbrand Apr 2 '13 at 0:02
  • Already fixed in upstream, there are several duplicate reports at bugzilla.redhat.com. Reported when F18 Alpha RC3 was released, but they've fixed it in March, after release. Too late... – GioMac Apr 8 '13 at 15:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.