0

I have installed Void linux which is otherwise working very well. It certainly is a smooth and stable distribution with a great package manager (xbps) which does dependency resolution also. The packages in repository (e.g. LibreOffice) are fairly recent.

However, I have not been able to make my Void Linux installation work with my HP Laserjet M1136 MFP printer/scanner. I have installed hplip and cups. I have tried to install it using command sudo hp-setup -i and also using localhost:631 on browser. The printer is recognized but on there is always 'Filter failed' error on trying to print.

This printer/scanner works well with a Debian Stable Linux installation on a separate partition of same desktop computer. I found that there is a package called hplip-data installed on Debian but this package is not present in Void Linux repository.

What could be the problem and how can it be solved? Thanks for your help.

Edit: /etc/printers.conf file is shown below:

NextPrinterId 12
<Printer HP_LaserJet_Professional_M1136_MFP>
PrinterId 11
UUID urn:uuid:64208fbb-c084-36f7-6ffd-55aa73ae7885
Info HP LaserJet Professional M1136 MFP
Location rnhome
MakeModel HP LaserJet Professional m1136 MFP hpijs, 3.20.9
DeviceURI hp:/usb/HP_LaserJet_Professional_M1136_MFP?serial=000000000QHBV1CYPR1a
State Idle
StateTime 1617539017
ConfigTime 1617539027
Type 8425484
Accepting Yes
Shared No
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy stop-printer
</Printer>

Edit: Printer started working after I used hp-plugin -i command. It downloaded required plugin and installed it. Thanks.

3

0

You must log in to answer this question.

Browse other questions tagged .