1

Solution

I've solved the problem by adding the initramfs flag in /etc/crypttab and using keyscript=decrypt_keyctl instead of a keyfile to avoid entering the password two times for the second drive:

luksSSD UUID=[UUID1]    none    luks,initramfs,discard,keyscript=decrypt_keyctl
luksHDD UUID=[UUID2]    none    luks,initramfs,keyscript=decrypt_keyctl

Afterwards update-initramfs -c -k all needs to be executed and the problem is solved.


Recently I've upgraded from Linux Mint 19.3 to 20.1 (with 20.0 as a step between). So now I am using Linux Mint 20.1 based on Ubuntu 20.04. My system is using two hard drives. They are encrypted using LUKS and contain a LVM VG.

On both hard drives there is a PV:

sudo pvs -v
  PV                  VG   Fmt  Attr PSize   PFree   DevSize  PV UUID                               
  /dev/mapper/luksHDD vglp lvm2 a--   <1,73t 266,62g   <1,73t [PV UUID1]
  /dev/mapper/luksSSD vglp lvm2 a--  463,89g   3,89g <463,90g [PV UUID2]

My crypttab is the following:

luksSSD UUID=[UUID1]    none    luks,discard
luksHDD UUID=[UUID2]    none    luks

On booting the computer I first get the following error message:

  Volume group "vglp" not found
  Cannot process volume group vglp
  Volume group "vglp" not found
  Cannot process volume group vglp

This happened already before the upgrade too.

Afterwards I am immediately asked for the password (the same for both volumes). Then the system was just booting without any problems before the upgrade.

But now it hangs for several seconds (about 20 seconds). Afterwards the following error message appears and the system hangs for roughly 1 minute:

  WARNING: Couldn't find device with uuid I[PV UUID1].
  WARNING: VG vglp is missing PV [PV UUID1] (last written to /dev/mapper/luksHDD).
  WARNING: Couldn't find device with uuid [PV UUID1].
  WARNING: VG vglp is missing PV [PV UUID1] (last written to /dev/mapper/luksHDD).

After this minute it just boots without any additional problems. I don't know where /dev/mapper/luks-hdd-neu comes from. I never used this path nor can I find it any file in /etc/.

Does anybody know why the boot process is hanging here. Why is the second PV not found first but then found later without problems?

Edit: After I run update-initramfs -c -k all instead of update-initramfs -u -k all the error message doesn't contain this weird /dev/mapper/luks-hdd-neu anymore and contains the right path. However, the system still hangs on boot.

Thanks in advance!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.