-1

I am trying to install anaconda navigator on kali linux Rolling , debian based , freshly updated. I used the command line found on anaconda official Linux Installing documentation https://docs.anaconda.com/anaconda/install/linux/:

apt-get install libgl1-mesa-glx libegl1-mesa libxrandr2 libxrandr2 libxss1 libxcursor1 libxcomposite1 libasound2 libxi6 libxtst6

And it shows this message always:

apt-get install libgl1-mesa-glx libegl1-mesa libxrandr2 libxrandr2 libxss1 libxcursor1 libxcomposite1 libasound2 libxi6 libxtst6
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
libasound2 is already the newest version (1.2.4-1.1).
libasound2 set to manually installed.
libxcomposite1 is already the newest version (1:0.4.5-1).
libxcomposite1 set to manually installed.
libxcursor1 is already the newest version (1:1.2.0-2).
libxcursor1 set to manually installed.
libxi6 is already the newest version (2:1.7.10-1).
libxi6 set to manually installed.
libxrandr2 is already the newest version (2:1.5.1-1).
libxrandr2 set to manually installed.
libxss1 is already the newest version (1:1.2.3-1).
libxss1 set to manually installed.
libxtst6 is already the newest version (2:1.2.3-1).
libxtst6 set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgl1-mesa-glx : Depends: libglapi-mesa (= 10.3.2-1+deb8u1) but 20.3.4-1 is to be installed
E: Unable to correct problems, you have held broken packages.

Same issue with Tensorflow installation using the command line:

sudo apt install libatlas-base-dev

Any help is welcomed.

1
  • 1
    Did you run apt-get update to refresh the local copy of the package database? Have you added any non-Kali package sources and/or installed any non-Kali packages? Apr 3, 2021 at 10:35

1 Answer 1

1

You have added the Debian Jessie repository to Kali that's why your have the unmet dependencies error.

Fix your sources using the following commands:

echo "deb http://http.kali.org/kali kali-rolling main non-free contrib" | sudo tee /etc/apt/sources.list
sudo rm /etc/apt/sources.list.d/*
sudo apt update
sudo apt remove libgl1-mesa-glx libegl1-mesa libxrandr2 libxrandr2 libxss1 libxcursor1 libxcomposite1 libasound2 libxi6 libxtst6

To install Anaconda navigator, download the installation script from the official website (It is a bash script, by default Kali Linux use ZSH) or use the following commands:

wget https://repo.anaconda.com/archive/Anaconda3-2020.11-Linux-x86_64.sh
sudo bash Anaconda3-2020.11-Linux-x86_64.sh
source ~/.bashrc

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .