2

I'm trying to install Debian 10 using this official ISO file:

http://cdimage.debian.org/cdimage/release/current/amd64/iso-cd/debian-10.9.0-amd64-netinst.iso

I modified this ISO file to automated with preseed.cfg, pack it using xorriso then write this ISO file into a disk called /dev/sdb using the following command:

wget -O mini.iso http://url_to_download_the_modified_debian_iso_with_preseed.iso
mv *.iso mini.iso
dd if=mini.iso of=/dev/sdb

Note that /dev/sdb is a second disk partition not a flash drive

Then when I boot this ISO using the /dev/sdb as the root drive, it can boot but presented the following dialog about 'No common CD-ROM drive was detected':

Screenshot 1

So, I can go ahead manually specifying the installation medium at the input dialog box to be /dev/sdb, then when I click continue the installation continues, here is the screenshot how I specify /dev/sdb in the input box and the installation continues without problem:

Screenshot 2

Since I want this to be automated, is there a way to mount this /dev/sdb automatically when the installation start before it scan the Disk? I couldn't find any preseed commands to skip this dialog box automatically.

I tried few of the following and add it in the preseed.cfg but doesn't work at all (I notice that the 3rd method, the script only run after I click continue after specifying the CD-ROM path to /dev/sdb in the dialog box)

1) d-i partman/early_command string mount /dev/sdb /cdrom

2) d-i cdrom-detect/cdrom_device string /dev/sdb
        
3)

d-i preseed/early_command string \
        umount /cdrom; \
        mkdir -p /cdrom; \
        mount -t vfat /dev/sdb /cdrom

Note that, if I use this ISO file to install in Virtualbox with a predefined preseed.cfg, it runs fine automatically until I got the working Debian OS (no CD-ROM dialog box) but in a linode server, it's a problem because it doesn't have CD-ROM enabled in their BIOS. So, the recommended way to install this ISO in linode is to boot from hard disk where I put the ISO directly to /dev/sdb

1

Debian netinst ISO image is created primarily to be burned on CD (DVD). Some years ago, it was slightly modified, so it can be saved on USB falsh disk. The modification adds a fake MBR sector which points to the first bootable partition starting at sector zero! I did not tried to place such ISO image onto regular disk device. The USB subsystem can recognise various types of USB device, USB mass storage and USB CD-ROM drive included.

The ISO image cannot be copied to USB flash in ordinary way, you definitely must use the command:

dd if=debian.iso of=/dev/sd_usbdevice

because you manipulate with data, that belong to block device.

Well I recommend you to keep the standard way. Better use the standard burned CD-R or USB flash disk.

If you insist on your way, please try to put the ISO image on the /dev/sdb with dd command. Than it depends on your chipset, if the ISO will be recognized.

4
  • I don't get it ... how can I use CD or USB flash drive on a VPS server remotely because this is a linode server (as I mentioned in the last post). Also, the command dd is what I use as mentioned in the post .. If I specify the installation path /dev/sdb when the CD-ROM dialog appear, then it work the installation complete but how do I automated this is a mystery which I cannot find any preseed config for this on the internet.
    – ToiletGuy
    Apr 3 at 10:28
  • By the way I'm super excited after you mentioned that netinst not suitable for booting from flashdrive. So, I found this linuxbabe.com/debian/boot-debian-9-iso-from-hard-drive-grub2 . Looking at the "Avoiding the Common Pitfall " section this is something that related to this issue. Haven't tried this yet, I will try.
    – ToiletGuy
    Apr 3 at 22:28
  • I think this is the one that I need to do in order to boot from hard drive, debian.org/releases/squeeze/amd64/ch05s01.html.en#boot-initrd
    – ToiletGuy
    Apr 3 at 22:37
  • I accept your answer first as you have given me the hint, I will come out with my answer for step by step how to do this to help others later especially when we don't have CDROM set in bios or the system could not find any CDROM drive when booting through hard disk. This is the case for remote server installation.
    – ToiletGuy
    Apr 4 at 11:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.