1

I tried to install a root-encypted Debian 11 (Bullseye, netinst, daily build 2021-03-29, cryptsetup) next to the existing Win 10 as Dual boot on a strict UEFI-only system (Dell Inspiron 17 7706, BIOS 1.3.0, 16GB RAM, 512 GB NVMe). Eventually I could shrink the Win10-partition, UEFI-boot the Netinst-Image, connect the Wifi (AX201) and install the encrypted Linux system, but grub-install and efibootmgr fail with "EFI variables are not supported on this system" modprobe efivars resp. modprobe efivarsfs fail either with "modprobe: FATAL: Module efivarsfs not found in directory /lib/modules/5.10.0-5-amd64/" Copying efivarsfs.ko there would make modprobe to work, but not grub-install/efibootmgr, leaving the system unbootable with Debian Linux (Win 10 boots).

I tried all the hints from "EFI variables are not supported on this system" but no success. Also tried the solutions from https://wiki.debian.org/GrubEFIReinstall no success either. Also tried rEFInd but it would not see my unenrypted boot-Partition at all.

/sys/firmware/efi/efivarsfs/ exists, but is empty. Secure boot is off.

Any ideas left?

Next step would be to try a plain new install of Ubuntu 20.10, but I'd like to stay with debian.

Thanks in advance for any help.

3
  • Did you update UEFI? And SSD firmware? Similar but you also have Xe graphics. Dell 7791 UEFI update & some settings ubuntuforums.org/showthread.php?t=2431450&page=3 Gen12 Xe Graphics might not be working out-of-the-box depending upon your kernel. This mentions boot parameter. phoronix.com/… but this says its only for developers. Please don't mention i915.force_probe in end-user documentation #980 github.com/intel/media-driver/issues/980 & cateee.net/lkddb/web-lkddb/DRM_I915_FORCE_PROBE.html – oldfred Apr 2 at 13:59
  • Thanks for the hints. AFAIK I installed all relevant updates offered by Dell support, which is System BIOS 1.3.0 (01 Apr 2021). So far I just installed the basic debian system without GUI. I also tried various BIOS options. Switching from RAID mode to AHCI made the complete system unusable, including Windows. I wonder why booting the D-I image is no problem at all, but booting a nvme partition seems impossible. I also tried to install EFI an /boot on an USB which did not work either. I guess I will try Ubuntu 20.10 next. – orinoco Apr 3 at 11:07
  • You should not need /boot with most desktop installs. If LVM with encryption or server type install then you may need a /boot. You have to install the AHCI drivers into Windows first then change to AHCI. Windows AHCI instructions - some have found safeboot method better dell.com/community/Laptops-General-Read-Only/… & askubuntu.com/questions/1233623/… SSD often need firmware update also. While not released, you might try 21.04 . – oldfred Apr 3 at 13:49
0

[Solved] The problem seems indeed the RAID ON resp. RST mode resp. Intel® Volume Management Device (VMD) vs. AHCI. As VMD is only supported by some Linux enterprise distributions (Redhat, SuSE, Ubuntu 18.04) (pdf) I decided to switch back to AHCI mode in order to stay with Debian¹.

Additional firmware or Windows AHCI-driver is not required. The crucial step is to deactivate VMD/optane memory in Windows (also turn off fast boot) and then switch to Windows safe boot. Then reboot and go with F12 into BIOS and switch from RAID ON to AHCI/NVMe. Then reboot into Windows in Safe Mode, turn off Safe Mode again and reboot normally into Windows. Now the system is fully functional with AHCI.

Then install Debian Bullseye as mentioned before. But at the end the "update-grub" hangs and you need to cold reboot. Booting into Debian was still not possible, but back into rescue mode I forced Debian to hijack the fallback boot loader and then it worked ("rescue mode" -> "rescue operations" -> "Force GRUB installation to the EFI removable media path") The error "EFI variables are not supported on this system" with efibootmgr and grub-install is still there, but who cares as long as the system does what it should?

Much help was also the install comparison of Debian buster and bullseye on an Acer machine with has quite similar hardware including optane and wifi²

¹ an install try with Ubuntu 21.04 failed completely.

² In order to activate wifi on the new Debian system, you need to disable(!) the wifi entry in /etc/network/interfaces which the D-I creates.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.