0

I want to install libsocketcan from source on my raspberry pi. I already installed libsocketcan on my Ubunutu VM successfully by following the instructions of the INSTALL file. Unfortunately the first step of the installation is is not working on the raspberry pi. The first step of the installation is to cd into the directory and to run ./configure but when i do this i get ./configure: No such file or directory. What can i do in this situation? I appreciate your help!

4
  • Is there a autogen.sh file? you may need to run that first, to generate the configure script Apr 1, 2021 at 22:51
  • @steeldriver yes there is an autogen.sh file.
    – mab0189
    Apr 1, 2021 at 23:02
  • You also need libtool
    – jsbillings
    Apr 1, 2021 at 23:07
  • @jsbillings you are right. I just found it out the hard way.
    – mab0189
    Apr 1, 2021 at 23:09

1 Answer 1

1

I finally got ./configure to work and could install libsocketcan on the raspberry pi. I did the following:

First i found this similar question. The answers suggested to install autoconf and automake and to run autoreconf -i. After i did this i could run ./configure atleast but i got the following error:

pi@RPI4:~/Repositorys/libsocketcan-0.0.12 $ ./configure
checking build system type... armv7l-unknown-linux-gnueabihf
checking host system type... armv7l-unknown-linux-gnueabihf
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether gcc understands -c and -o together... yes
./configure: line 3175: syntax error near unexpected token `win32-dll'
./configure: line 3175: `LT_INIT(win32-dll)'

I ran the autoreconf -i again and i suddendly got this different output:

src/GNUmakefile.am:1: error: Libtool library used but 'LIBTOOL' is undefined
src/GNUmakefile.am:1:   The usual way to define 'LIBTOOL' is to add 'LT_INIT'
src/GNUmakefile.am:1:   to 'configure.ac' and run 'aclocal' and 'autoconf' again.
src/GNUmakefile.am:1:   If 'LT_INIT' is in 'configure.ac', make sure
src/GNUmakefile.am:1:   its definition is in aclocal's search path.
autoreconf: automake failed with exit status: 1

A quick search of the error suggested to install libtool with sudo apt-get install libtool. I did this and ran autoreconf -i again. After this the ./configure finally worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .