4

Linux Mint 20.1 with Cinnamon opens the terminal when hitting Super+2 and brings windows to the front with Super+3 and Super+4. Super meaning the Windows-Key.

I would like to use these shortcuts otherwise, but going into the shortcuts tab of the "keyboard" window, the unwanted shortcuts are not even registered there, so I can't unbind them. Are they maybe a remnant of Ubuntu, and most importantly: how do I remove / disable these pre-defined shortcuts?

PS: Here's screenshots of my shortcut settings; I want Super+2 to switch to workspace 2, nonetheless it opens the terminal.

Screenshot Screenshot2

Edit:

This is the (relevant) output of dconf dump /:

[org/cinnamon/desktop/keybindings/wm]
push-tile-left=@as []
push-tile-right=@as []
switch-to-workspace-1=['<Super>1']
switch-to-workspace-2=['<Super>2']
switch-to-workspace-3=['<Super>3']
switch-to-workspace-4=['<Super>4']
switch-to-workspace-left=['<Super>Left']
switch-to-workspace-right=['<Super>Right']

so the shortcuts I want are correctly registered there.

8
  • By "Start" you mean Super (the Windows key), right? Is this in Gnome? Or Mate? Can't you just set the shortcut anyway? Most systems will tell you "this key combination is bound to XXXX; overwrite?" and you can say yes and overwrite the existing one. – terdon Apr 1 at 18:17
  • Thanks for pointing those out, added more information. I mean the "Windows" key, and I'm using Cinnamon. I have those shortcuts already assigned (but wasn't asked to overwrite), they just still execute the old / pre-existing commands (Start+2 opens Terminal etc); these shortcuts seem to be bound outside of LM's / Cinnamons usual shortcut mechanisms. – fweigl Apr 1 at 18:29
  • Thanks for the edit, that helps. You should be able to see all keybindings (with some exceptions such as tools like xbindkeys but I doubt you would have this and not know it) using dconf. Please edit your question and add the output of dconf dump / | grep -C3 -F "binding=['<Super>". That should show all keybindings using Super+ something. We can take it from there. – terdon Apr 1 at 19:51
  • @terdon Thanks for your help and sorry for the late reply, the output of the expression was empty, I found the relevant part in the output of dconf dump / though. – fweigl Apr 6 at 19:51
  • Are those the only occurrences of the string Super in that dump? – terdon Apr 6 at 21:05
3
+300

Unfortunately, I have too few points to leave a comment to ask my questions. This might be a dumb question, but have you tried rebooting?

I haven't used Cinnamon in ages, but it's based on GNOME, so many of the GNOME commands used to work on it (what I'm trying to say is that 'approach 1' might be obsolete)

If that doesnt work, you might have more luck trying this:

Approach 1 (this one used to work):

  1. Open up a terminal and write gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-1 "[]".
  2. Then, write gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-1 ['<Super>1'].
  3. Reboot to see if the changes stuck.

Approach 2:

  1. Open up a terminal and write dconf-editor.
  2. Go to org.cinnamon.muffin.keybindings.
  3. Set switch-to-workspace-1 from ['<Super>1'] to [].
  4. Reboot.
  5. Check if Super+1 does anything, if nothing happens, I'm confident the next steps will solve your problem.
  6. Open up a terminal and write dconf-editor.
  7. Go to org.cinnamon.muffin.keybindings.
  8. Set switch-to-workspace-1 from [] to ['<Super>1'].
  9. Reboot again.
2
  • 1
    At first, it didn't work, then I found this: superuser.com/questions/1548836/…. I must have overlooked this when first looking for answers. Now everything works fine! Still not great design by LM / Gnome / Cinnamon / whoever to hide pre-defined shortcuts like that, but whatever. In the end I don't know if disabling the "applets" shortcuts would have been enough, that would be for someone else to try, but your answer got me on the right track :) – fweigl May 20 at 14:52
  • Even though my methods didn't work, I'm glad you managed to sort it out as a consequence :D – telometto May 20 at 18:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.