1

I've spent the last hours trying to figure out how to get my wifi working. Today I updated from Pop_OS 20.04 to 20.10. Everything worked fine, but after an hour my 5GHz Wifi connection stated constantly dropping over and over again. So I restarted the network manager and the 5GHz network was gone. I then decided to just use the 2.4GHz one, which worked for a while until it started disconnecting too. After another hour I couldn't even use the internet anymore, as it constantly kept connecting and disconnecting (in a 5 second rythm). Then I finally started trying to fix the problem. At first I tried searching online which brought me to the idea to reinstall bcmwl-kernel-source, which then resulted in it not being able to reinstall anymore. Nothing network related with my network card works at the moment.

This is the error I am getting:

image


Reading package lists... Done
Building dependency tree       
Reading state information... Done
dkms is already the newest version (2.8.3-4ubuntu0.1).
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up bcmwl-kernel-source (6.30.223.271+bdcom-0ubuntu7) ...
Removing old bcmwl-6.30.223.271+bdcom DKMS files...

Deleting module version: 6.30.223.271+bdcom
completely from the DKMS tree.

Done.
Loading new bcmwl-6.30.223.271+bdcom DKMS files...
Building for 5.11.0-7612-generic
Building for architecture x86_64
Building initial module for 5.11.0-7612-generic
ERROR (dkms apport): kernel package linux-headers-5.11.0-7612-generic is not supported
Error! Bad return status for module build on kernel: 5.11.0-7612-generic (x86_64)
Consult /var/lib/dkms/bcmwl/6.30.223.271+bdcom/build/make.log for more information.
dpkg: error processing package bcmwl-kernel-source (--configure):
 installed bcmwl-kernel-source package post-installation script subprocess returned error exit status 10
Errors were encountered while processing:
 bcmwl-kernel-source
E: Sub-process /usr/bin/dpkg returned an error code (1)

Same happens with all the broad broadcom-sta-dkms and all the other broadcom-sta-*

packages too (I tried installing them from source and from deb).

I always get this error in some form of telling me the 5.11 Kernel is not supported.

I own/have this problem with a ASUS PCE-AC68 network card btw (here the Chip ID (I think?): 14e4:43a0).

I don't know how to fix this problem without downgrading to Pop_OS 20.04 again. And it seems like just starting from scratch with a new install seems easier, I just really hope somebody can help me out here :/

1 Answer 1

0

I know it may not help your situation, since you did a full release upgrade, but I was able to revert using TimeShift.

If you do a full re-install, you can probably go to 20.10 just fine, and install the Broadcom drivers, but just DO NOT install the latest updates. It appears they have updated the kernel from 5.8 to 5.11 and the broadcom drivers do not support this (yet).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.