0

My OS is Debian stretch (mate Desktop) Since about 2 years I have a problem with default setting for application browser(in mate-control-center) and firefox. whenever I let firefox set itselfs as default browser in (about:preferences) my prefered application settings in mate-control-center changed from firefox-esr to thunderbird for default browser. And the other way around.

Both seemed somehow registert

 alex@Taomon:~$ gvfs-mime  --query x-scheme-handler/http 
    Default application for 'x-scheme-handler/http': firefox-esr.desktop
    Registered applications:
        thunderbird.desktop
        firefox-esr.desktop
    Recommended applications:
        thunderbird.desktop
        firefox-esr.desktop
    alex@Taomon:~$ 

alex@Taomon:~$ gio mime x-scheme-handler/https
Default application for 'x-scheme-handler/https': firefox-esr.desktop
Registered applications:
    thunderbird.desktop
    firefox-esr.desktop
Recommended applications:
    thunderbird.desktop
    firefox-esr.desktop
alex@Taomon:~$ 

How can I remove thunderbird as registered application for x-scheme-handler/http and x-scheme-handler/https. I hope then my Error will be gone for good.

edit

In ubuntu (focal) is only firefox registert.

alex@Guilmon:~$ gio mime x-scheme-handler/http
Default application for “x-scheme-handler/http”: firefox.desktop
Registered applications:
        firefox.desktop
Recommended applications:
        firefox.desktop
alex@Guilmon:~$ 

there is also thunderbird as e-mail client installed.

1
  • Also present in bullseye live session.
    – nobody
    Nov 19, 2021 at 14:50

2 Answers 2

0

Sorry if you actually tried the obvious one but have you set Firefox as your default browser in Preferred Application settings?

enter image description here

For me Firefox is set to default in Preferred Applications AND in Firefox.

2
  • Yes of course I did. But then I start firefox, it says I'm not your default browser wenn I click on set as default browser in mate-control-center modul prefered applications it is changed to thunderbird. In my case it is in system, because by my unmodified test user the same behavior. Maybe it is time for a fresh install after over a decade from release upgrades.
    – nobody
    Mar 30, 2021 at 16:13
  • Ok I think I never clicked on set-as-default-browser I just clicked on the X and never had a problem.
    – Mickey
    Mar 30, 2021 at 16:50
0

it turned out it was a bug in thunderbird.

bugreport

After upgrading thunderbird to version 1:91.7.0-2~deb10u1 this behaviour is gone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.