0

My system keeps booting into the Grub2 Command Line interface on startup. I used to run Windows 10 and Ubuntu on Dual Boot, and after I updated my Windows 10 to Windows Server 2019, on every startup, the PC goes into the Grub2 Command Line interface. I know how to get the PC into Windows. I have to enter the Boot Options (F9) and go to EFI Boot > Microsoft > Boot > bootmgfw.efi. I have to do this on every startup, which is very annoying. I also wiped the Linux partition, and it's still booting into Grub2. I've tried to change to Boot Order to boot my SSD (Windows) first, Changed UEFI Native ( Without CSM ) to UEFI Hybrid ( With CSM ), changed UEFI to Legacy boot, and I've checked some more answers on StackExchange, but they all have answers to how to get into Windows and not how to get rid of Grub.

Some More Info:

On Boot, Grub2 says, "System BootOrder not found. Initializing defaults. Creating boot entry "Boot0027" with label "ubuntu" for the file "\EFI\ubuntu\shimx.efi"

Previously I had Ubuntu 20.04 on an HDD and Windows 10 Professional on an SSD. Now I'm having the HDD filled with Data and the SSD with Windows Server 2019 Datacenter Desktop Experience with Fast Boot On. ( I tried turning Fast Boot off, but it didn't do anything )

I've set Task Scheduler to resume from hibernation at 7 AM every morning, but it goes into Grub2 on resuming.

Any help will be appreciated.

1
  • To get rid of UEFI version of GRUB created by Ubuntu, delete the \EFI\Ubuntu directory from the ESP partition.You might also want to copy \EFI\Microsoft\Boot\bootmgfw.efi to \EFI\BOOT\bootx64.efi overwriting any existing file there. You'll also need to fix your UEFI NVRAM boot variables. If you need help on how to do it with Windows tools, ask on SuperUser.SE instead - use of Windows tools is off topic here. – telcoM Mar 30 at 6:24
0

It seems you have an EFI machine, thus UEFI loads defined bootloader from a small FAT GPT partition which is usually mounted on Linux as /boot/efi (depends on distro). And because you get GRUB2 it's more probably you have GRUB2 installed as /EFI/BOOT/BOOTX64.EFI inside EFI partition.

Check what files you have in this partition. To fix it in Windows see https://superuser.com/a/504360/1000930

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.