0

I created an ubuntu bootable USB stick using my windows 7. Then disconnected my HDD, powered on and changed the BIOS setting to legacy and booted from the bootable USB(changed to legacy because I couldn't boot from the USB stick), I then inserted another USB stick to do a full install of ubuntu using "Something else". I partitioned that USB stick to have an EFI and another partition for ubuntu. Everything went well. Then I removed the bootable stick, reboot, and boot from the stick that has the full installation. Again everything is okay. I turned off, removed the stick, connected the HDD, and try to boot into windows 7 but I can't. I tried accessing the BIOS but I couldn't. Basically the laptop powers on, shows my motherboard logo, with "Press F2 for setup" which does nothing and then it goes into the screen shown in the picture with ubuntu as an option for boot.(not shown here). So I tried removing the CMOS battery and plugging it back again and the ubuntu option was gone.(as shown in picture). And now I can't boot into anything and can't access the bios. What do I do :(

enter image description here

The setup menu that shows up after I press TAB is also empty.

1
  • What brand/model system? What video card/chip? Did you actually install in UEFI boot mode, as how you boot install media, is then how it installs. help.ubuntu.com/community/UEFI If UEFI hardware, best to always boot in UEFI mode. Lets see details, use ppa version with your live installer (2nd option) or any working install, not Boot-Repair ISO: Please copy & paste the pastebin link to the Boot-info summary report ( do not post report), do not run the auto fix till reviewed. help.ubuntu.com/community/Boot-Repair
    – oldfred
    Commented Mar 30, 2021 at 12:41

1 Answer 1

0

My laptop is Samsung NP300e4c, it turns that the BIOS on these laptops has a bug! Once you set the settings in the BIOS to boot in legacy mode, which I had to do in order to boot from the USB stick, you can't access the BIOS again to set it back. The only solution is to take the BIOS chip and reflash it with the default binary that you can find somewhere.

Here's more info:

https://www.youtube.com/watch?v=fMXBI_hhhjg&ab_channel=1nformatica

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .