So I wanted to try out Urban Terror on Fedora 18. I installed it. When I click it, the screen resolution would change to a lower resolution(800x600) to play the game in full screen. Then after I've exit the game the resolution would remain the same. I tried changing the resolution in the 'Displays' application to 1440x900, the screen would go blank forever and I would have to restart the PC. After restart the resolution would return to normal.

So after a few tries trying to replicate the issue, the screen went blank but after restart it never returned 1440x900. Now I'm stuck on the low 800x600. It does work on 1440x900 until login screen but after I login it goes to 800x600 that Urban Terror had set. Something seems to be broken after the login screen.

Forcing the resolution to 1440x900 in the /etc/gmd/Init/Defaults still doesn't change anything.


Find the best resolution for your monitor in documentation, it should be a string like 1680 x 1050 @ 60Hz (perhaps, 1440x900@60Hz in your case?).

Try cvt command to create a mode line to feed it then to xrandr:

$cvt 1680 1050 60 -- substitute the values you've found for your monitor!

You'll get a string like:
1680x1050_60.00" 146.25 1680 1784 1960 2240 1050 1053 1059 1089 -hsync +vsync

Then try to create a new mode for this resolution using xrandr:

$xrandr --newmode "1680x1050_60.00"  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync

You may get an error like:

X Error of failed request: BadName (named color or font does not exist)

In which case try to modify the mode name from 1680x1050_60.0 to 1680x1050_OK or something different anyway.

You shouldn't get the error this time with the --newmode command above, so you can set this new resolution:

$xrandr --addmode VGA-1 1680x1050_OK

The above procedure worked for me, although I don't know the reasons why my resolution dropped and the system was unable to "detect" it without my help. I filed a bug anyway.


First change the rotation of the screen, then change the resolution to 1440*900 and the last step is changing again the rotation to the correct option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.