0

Setup

I'm trying to build a new media PC, and chose a low-power Intel Core i5 10600T processor, which has an integrated UHD 630 graphics chip. The motherboard is an ASUS Prime B560M-A and the display used is a Sony Bravia KDL-55W905A. I am using Debian testing (Bullseye), XFCE and lightdm.

Problem details

It seems that no displays are detected by the graphics chip at all. I get graphics at boot time and in BIOS, but when the system tries to start X, the screen goes blank permanently. Nothing is displayed in the X terminal and regular terminals cannot be accessed with for ex. Ctrl-Alt-F[something].

However, as expected, the computer responds normally to SSH access and I can interact with it remotely.

The Xorg log file is here: https://pastebin.com/XCpjxe3y

The offending line seems to be this: [ 3.859] (WW) modeset(0): No outputs definitely connected, trying again...

lspci -v gives this output which seems fine:

00:02.0 VGA compatible controller: Intel Corporation CometLake-S GT2 [UHD Graphics 630]                                                                                                                                                      (rev 03) (prog-if 00 [VGA controller])
        DeviceName: Onboard - Video
        Subsystem: ASUSTeK Computer Inc. UHD Graphics 630
        Flags: bus master, fast devsel, latency 0, IRQ 140, IOMMU group 1
        Memory at 6000000000 (64-bit, non-prefetchable) [size=16M]
        Memory at 4000000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 3000 [size=64]
        Expansion ROM at 000c0000 [virtual] [disabled] [size=128K]
        Capabilities: [40] Vendor Specific Information: Len=0c <?>
        Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [ac] MSI: Enable+ Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 2
        Capabilities: [100] Process Address Space ID (PASID)
        Capabilities: [200] Address Translation Service (ATS)
        Capabilities: [300] Page Request Interface (PRI)
        Kernel driver in use: i915
        Kernel modules: i915

dmesg log shows problems with the video card at 1.046225, 1.061414, 1.063566 and 1.063917: https://pastebin.com/M1DCCDZ4

What have I tried

For the record, I have an older and slower media PC machine with Core i5 4590T and its integrated graphics chip. This system works perfectly fine with the same TV.

  • The motherboard has two HDMI outputs and one DP output. None of these work.
  • Different cables have been tried, including cables which work with the same TV and the older media PC machine.
  • When booting from an Ubuntu liveCD, The exact same thing happens.
  • I cannot access xrandr to check on displays, because X does not start.
  • Setting i915.modeset=0 in grub config gets me to X at 1024x768 (only). In this state, xrandr runs, but does does not seem to give any sensible output and the resolution cannot be changed from X settings.
  • Finally, the xserver-xorg-video-intel package description states that it should not be used for systems newer than 2007. I have uninstalled the package, but this did not seem to have any effect. The Xorg log after this has been done is here: https://pastebin.com/MwqvwmWL

I'm at my wit's end. Of course I could order a low-end graphics card and add it to the system, but would prefer not to. Any help is appreciated.

Additional questions

As said, if I set i915.modeset=0, I get to X, but the graphics are severely limited. I am also unsure about what the option truly does internally. Can I work with this state in some way to force a better resolution? Does HW acceleration work in this state?

2
1

I tried compiling the kernel but it didn't work

I added the kernel version 5.13 using https://wiki.debian.org/DebianExperimental

sudo apt -t experimental install linux-image-amd64

it worked like a charm

2
  • What errors did you get while compiling the kernel. Was it related to something else in the kernel compilation process or do you mean that you compiled the kernel successfully and the problem was not resolved?
    – Warma
    Sep 2 at 13:00
  • Kernel was compiled successfully , while make install I got few messages that firmware files for i915 were missing. But when I tried to use the new kernel(5.14+) the system would not boot. Sep 2 at 18:45
0

User Artem Tashkinov recommends an updated kernel, and the same advice was given at #intel-gfx in Freenode. Building a new kernel from the intel gfx drm-tip (see https://01.org/linuxgraphics/documentation/build-guide-0) resolved the issue for me. Based on discussions in #intel-gfx, the fix is not yet implemented in mainline kernels, which means that compiling your own is the only solution at the moment.

Moreover, the issue seems to be the same as these filed bugs, refer to them for additional information: https://gitlab.freedesktop.org/drm/intel/-/issues/3286 https://gitlab.freedesktop.org/drm/intel/-/issues/2742

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.