1

I have a Canon scanner and Iḿ trying to install it on a QubesOS machine. In one qube (virtual machine) I have a fresh Debian 10 install, in the other a fresh Fedora 32 install. The printer drivers are available from Canons webpage and have a bash install script that is available for multiple distros. So I install it in both qubes, and that all works fine. After that printing works for both qubes without problems.

Then I also install gscan2pdf in both qubes. In Fedora, when I launch gscan2pdf I can easily select my Canon scanner and the source for the pages (flatbed or document feeder). However in Debian gescan2pdf does not recognize the scanner.

Running sudo sane-find-scanner in both Fedora and Debian results in the same message:

found USB scanner (vendor=0x04a9 [Canon], product=0x27fe [MF642C/643C/644C]) at libusb:001:002
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage

However in Debian sudo scanimage -L gives me:

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

While runningsudo scanimage -L in Fedora gives me:

device `pixma:04A927FE_349f7ba38c13' is a CANON Canon i-SENSYS MF640 Series multi-function peripheral

It seems Fedora by default is able to recognize the scanner while Debian is not.

Sane-pixma is installed on Debian however and is supposed to recognise it.

Anyone has any idea how I could troubleshoot this further and find the cause?

1 Answer 1

2

Debian 10 has SANE version 1.0.27, while Fedora 32 has version 1.0.32.

Unfortunately it looks like the support for Canon i-SENSYS MF64x series was added to sane-pixma somewhere in between those versions, and that's why Debian's version will not recognize it.

1
  • Yep, I just installed via GIT and now it works! Although it took 2 attempts. It seems pixma-backend (which is needed) only gets buils when you have a JPEG library installed. So I installed libjpeg-dev and then rebuild sane-backends via GIT and now it works!!
    – Montmons
    Mar 28, 2021 at 15:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .