3

Intel Sandy-Bridge family i5 Core CPU, running Linux kernel 3.2 (Debian Squeeze/Wheezy), under heavy computation load, does not react to to cpufreq-set -g powersave (using acpi_cpufreq module). It is 99.9% time running in turbo mode, although it seems to be somehow throttled automatically, as can be seen in kernel messages (dmesg):

...
[137547.968129] CPU2: Package temperature/speed normal
[137547.968130] CPU0: Package temperature/speed normal
[137548.124277] CPU2: Core temperature above threshold, cpu clock throttled (total events = 16455155)
[137548.124280] CPU3: Core temperature above threshold, cpu clock throttled (total events = 16455154)
[137548.125289] CPU2: Core temperature/speed normal
[137548.125291] CPU3: Core temperature/speed normal
[137847.287143] CPU2: Package temperature above threshold, cpu clock throttled (total events = 17888019)
[137847.287147] CPU3: Package temperature above threshold, cpu clock throttled (total events = 17888017)
...

I'd like to turn this CPU to power-saving mode, or choose the frequency, like with good old cpufreq powersave or userpace cpufreq governors. I wonder, what manual throttling method would work on these CPUs..

  • I experience similar problems too, I don't think that really matters, what's your model, X220? – daisy Feb 9 '13 at 3:13
  • Sounds like maybe acpi_cpufreq isn't working—in which case userspace governor won't work either. That'd be a BIOS problem, probably. – derobert Feb 9 '13 at 3:17
  • warl0ck, it's classified :) CPU model is i5-2520M – mykhal Feb 9 '13 at 3:18
  • derobert: i think that the acpi_cpufreq module was the only cpufreq driver able to load – mykhal Feb 9 '13 at 3:22
  • warl0ck: my another issue on this laptop was, that even when idle, fan was relatively loud and power draw ~15W.. even with i195.i915_enable_rc6=7 option.. it was fixed by switching from archlinux to debian (maybe a bug in very recent kernels). now in idle it's silent, ~9W, like in win7. – mykhal Feb 9 '13 at 3:28
0

It is not easily possible to scale down the CPU speed to a certain frequency, but in this blogpost, you find a script to disable turbo-boost: http://notepad2.blogspot.com/2014/11/a-script-to-turn-off-intel-cpu-turbo.html

(This will probably solve the issue for many searchers, that ended up here.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.