1

I am using an up-to-date version of manjaro mate and have virt-manager 3.2.0-1 installed on my Thinkpad E14 (AMD Ryzen 5 4500U). Using either GNOME Boxes or virt-manager it is really slow:

enter image description here

It really bothers me because I know it just work flawlessly in the past. Unfortunately I don’t know what update caused this issue. I did a reinstall but the issue still persists. I tried using Ubuntu MATE but it is also very slow there. I used quickemu as well and it just worked perfect back then, currently installation fails.

I do not know whether this issue has something to do with this one. But there I got a error

/usr/share/libdrm/amdgpu.ids: No such file or directory

and actually amdgpu.ids is located in/var/lib/mhwd/ids/pci/amdgpu.ids.

I know the data availability is not great but maybe someone with AMD Ryzen experiences similar issues that can be resolved.

I tried using virtualbox and there are no performance issues, however I really prefer using GNOME Boxes or virt-manager.

Thanks for any ideas!

2
  • Please show qemu cmdline as it is visible in ps -axo args | grep '[q]emu'.
    – Jiri B
    Mar 29, 2021 at 11:52
  • this commando shows nothing :(
    – Mickey
    Mar 29, 2021 at 12:37

3 Answers 3

2

I was wrong to say the code to mitigate spectre/meltdown was the reason for the low performance. Turns out virt-manager was locked to one core which I fixed it by changing Whonix-Workstation*.xml at line 12 (approx) remove cpuset =1 and between opening and closing brackets of vcpu define the amount of cores Eg.4 . Then applying the changes using

sudo virsh -c qemu:///system define Whonix-Workstation*.xml

In my case I had 8 logical cores I assigned half to the Gateway and half to workstation so they don't overlap.

1

It's slow even for me. It's because they included code to mitigate spectre and meltdown attacks on the hypervisor.

2
  • Welcome to the site, and thank you for your contribution. Perhaps you could add some links to references for the statements you made?
    – AdminBee
    Jun 9, 2021 at 9:49
  • But why is virtualbox then fine?
    – Mickey
    Jun 10, 2021 at 8:20
0

So I changed the video settings to Virtio and now it's running pretty decent!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .