I know this was asked a lot of times, but honestly I've tried everything that I could find over the internet and still couldn't resolve this.

I am a beginner user of Ubuntu 20.04 and I am having issues setting A2DP profile for a pair of bluetooth headset, and the quality is very bad.

  • I have paired, trusted and connected the headphones via terminal bluetoothctl then pair, trust, connect, didn't work
  • also installed Blueman and did the same process there again with no luck

After this I've tried to:

  • set the profile A2DP firstly from OS GUI that didn't work
  • then I've tried from Blueman but no success here either -> (Failed to change profile to a2dp_sink)
  • installed pavucontrol and tried again from there - in pavucontrol I go to Config tab and in headphone's profile dropdown I can see High Fidelity Playback (A2DP Sink)(unavailable) so of course, I cannot set it here also

I have also checked pacmd list-cards, checked the index of headphones, then pacmd set-card-profile <index> a2dp_sink but I get Failed to set card profile to 'a2dp_sink'.. I've also tried to sudo pacmd set-card-profile <index> a2dp_sink and now I get No PulseAudio daemon running, or not running as session daemon. PulseAudio is installed, I've checked with pulseaudio --version pulseaudio 13.99.1.

I've edited the /etc/bluetooth/audio.conf file and added this line in the end of it: Disable=Headset, this didn't work. I've also tried to add same line in main.conf - no success.

With bluez installed, I've also enabled this line Name = BlueZ in /etc/bluetooth/main.conf, again nothing.

In /etc/bluetooth/main.conf I've also uncommented #MultiProfile = off and changed it to MultiProfile = multiple, nothing happened.

So after mixing all the steps above and restarted bluetooth and re paired headphone a million times, I gave up and I'm writing for help.

Please give any hint on what could be the issue.


3 Answers 3


Have you tried doing the following?

"If PulseAudio fails when changing the profile to A2DP with bluez 4.1+ and PulseAudio 3.0+, you can try disabling the Socket interface from /etc/bluetooth/main.conf by removing the line Enable=Socket and adding line Disable=Socket." And then restart using sudo systemctl restart bluetooth

Source: Archwiki bluetooth Headset Page

This solution worked for me on Pop! OS 20.04 LTS.

Edit: I faced the same issue again, and removing Disable=Socket line from the /etc/bluetooth/main.conf makes it work again. Will update with any more changes...but I am not sure how world works anymore.

  • I did, but it did not help
    – tiriana
    Oct 5, 2021 at 11:39
  • 'systemctl' not sytemctl, using just sudo systemctl restart bluetooth worked for me
    – Nitaa a
    Jul 12, 2022 at 13:24
  • 1
    Worx on ubuntu 20.04.4 LTS. Just Added Disable=Socket to the end of /etc/bluetooth/main.conf (it wasn't defined at all), restarted bluetooth. Cheers
    – Jadeye
    Jul 20, 2022 at 8:28

I too tried so many things but after a restart, I just did "killall pulseaudio", my system automatically reconnected with my headphone and problem is gone

  • Just tried this and it helped.
    – tiriana
    Oct 5, 2021 at 11:39
  • ` killall pulseaudio pulseaudio: no process found ` As I switchted to pipewire. Problem persists
    – Qohelet
    Dec 1, 2021 at 10:20

After doing some research, what I found was when selecting headset's mic output, ubuntu does not allow to use a2dp. a2dp selected

Headset with mic selected

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .