2

I was previously using tmux in Kubuntu 19.10 (where my keybinding worked) and just upgraded to Kubuntu 20.04 (where the binding no longer works). I don't know the previous tmux version but currently it's tmux 3.0a.

The broken keybinding is: bind-key \ split-window -h -c '#{pane_current_path}'. I can manually invoke split-window -h -c '#{pane_current_path}' to create the new pane, but that's nearly impossible to remember&type.

The similar keybinding: bind-key - split-window -v -c '#{pane_current_path}' still works. And all my other config seems to still be working.

I've tried bind-key -n \ split-window... guessing that the -n argument might help, but it did not. I don't know any other possibilities to try, or how to troubleshoot/debug this.

1 Answer 1

2

You will need to escape the backslash, or quote it:

bind-key \\ split-window -h -c '#{pane_current_path}'

or

bind-key '\' split-window -h -c '#{pane_current_path}'

... otherwise you get an error:

unknown key: split-window

The error comes from tmux trying to assign a command to the key split-window (note the initial space, which you added there by escaping it with \).

1
  • 1
    I wish I could vote for this multiple times to express an appropriate level of gratitude <3
    – alec
    Mar 27, 2021 at 15:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .