0

The drive was working fine booting to Ubuntu Mate on a RPi4. I reformatted it before attempting to use it with Berryboot on a new RPi4. During BB installation I got an "Unable to unmount ..." error message but continued and installation of Raspbian seemed successful. On rebooting though, I got a series of error messages and couldn't even get into the console mode that was offered - just looping. I removed it, thinking to reformat and flash the Raspbian image directly to it, abandoning berryboot. But now my Manjaro Gnome desktop can't access it. Nothing shows in Disks or Gparted. However, the log from dmesg (below) seems to show that the system knows it's there and is trying to find a way in... But that's the limit of my own understanding and I'm hoping someone more knowledgeable will be able to tell me if the SSD is bricked or there's a way to recover it. (I'm quite sure it's not the cable, btw!)

[27958.059701] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[27962.563005] usb 2-1: Device not responding to setup address.
[27962.773004] usb 2-1: Device not responding to setup address.
[27962.979681] usb 2-1: device not accepting address 97, error -71
[27964.829787] usb 2-1: Device not responding to setup address.
[27965.039755] usb 2-1: Device not responding to setup address.
[27965.246367] usb 2-1: device not accepting address 98, error -71
[27965.246455] usb usb2-port1: attempt power cycle
[27969.619815] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[27977.136538] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[27981.309911] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[27985.349948] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[27992.173343] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[27992.733351] usb 2-1: new SuperSpeed Gen 1 USB device number 100 using xhci_hcd
[27992.750695] usb 2-1: New USB device found, idVendor=152d, idProduct=0562, bcdDevice= 2.04
[27992.750701] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[27992.750705] usb 2-1: Product: USB3.1 TO NVME SSD
[27992.750708] usb 2-1: Manufacturer: Liangteng
[27992.750711] usb 2-1: SerialNumber: DD20180910888
[27992.755322] scsi host13: uas
[27992.755602] scsi 13:0:0:0: Direct-Access     ITHOO    Tech             0204 PQ: 0 ANSI: 6
[27992.756009] sd 13:0:0:0: Attached scsi generic sg2 type 0
[27994.536635] usb 2-1: USB disconnect, device number 100
[27994.536829] sd 13:0:0:0: tag#5 uas_zap_pending 0 uas-tag 1 inflight: CMD 
[27994.536836] sd 13:0:0:0: tag#5 CDB: Test Unit Ready 00 00 00 00 00 00
[27994.740047] sd 13:0:0:0: [sdb] Read Capacity(16) failed: Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
[27994.740053] sd 13:0:0:0: [sdb] Sense not available.
[27994.940027] sd 13:0:0:0: [sdb] Read Capacity(10) failed: Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
[27994.940035] sd 13:0:0:0: [sdb] Sense not available.
[27995.020071] sd 13:0:0:0: [sdb] 0 512-byte logical blocks: (0 B/0 B)
[27995.020076] sd 13:0:0:0: [sdb] 0-byte physical blocks
[27995.086718] sd 13:0:0:0: [sdb] Write Protect is off
[27995.086724] sd 13:0:0:0: [sdb] Mode Sense: 00 00 00 00
[27995.153389] sd 13:0:0:0: [sdb] Asking for cache data failed
[27995.153395] sd 13:0:0:0: [sdb] Assuming drive cache: write through
[27995.583395] sd 13:0:0:0: [sdb] Read Capacity(16) failed: Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
[27995.583400] sd 13:0:0:0: [sdb] Sense not available.
[27995.783396] sd 13:0:0:0: [sdb] Read Capacity(10) failed: Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
[27995.783402] sd 13:0:0:0: [sdb] Sense not available.
[27996.116733] sd 13:0:0:0: [sdb] Attached SCSI disk
[28000.403421] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28004.446787] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28008.620161] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28012.660199] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28016.833566] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28022.540260] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28029.777038] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28039.027104] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28045.670502] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28050.317265] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28054.357241] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28055.913914] usb 2-1: new SuperSpeed Gen 1 USB device number 101 using xhci_hcd
[28061.057336] usb 2-1: New USB device found, idVendor=152d, idProduct=0562, bcdDevice= 2.04
[28061.057342] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[28061.227242] usb 2-1: USB disconnect, device number 101
[28065.570677] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28069.744041] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28077.630789] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28081.804158] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28085.844197] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28090.017597] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28094.057605] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28098.230975] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28102.271013] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28112.761109] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28117.407815] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28121.751190] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28131.897945] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28135.937988] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28142.054706] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28146.768079] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28154.911501] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28158.951530] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28163.464900] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28165.848241] usb 2-1: new SuperSpeed Gen 1 USB device number 103 using xhci_hcd
[28165.865580] usb 2-1: New USB device found, idVendor=152d, idProduct=0562, bcdDevice= 2.04
[28165.865586] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[28165.865590] usb 2-1: Product: USB3.1 TO NVME SSD
[28165.865593] usb 2-1: Manufacturer: Liangteng
[28165.865596] usb 2-1: SerialNumber: DD20180910888
[28165.870697] scsi host13: uas
[28165.871387] scsi 13:0:0:0: Direct-Access     ITHOO    Tech             0204 PQ: 0 ANSI: 6
[28165.872223] sd 13:0:0:0: Attached scsi generic sg2 type 0
[28165.873122] sd 13:0:0:0: [sdb] 250069680 512-byte logical blocks: (128 GB/119 GiB)
[28165.873128] sd 13:0:0:0: [sdb] 4096-byte physical blocks
[28165.873268] sd 13:0:0:0: [sdb] Write Protect is off
[28165.873272] sd 13:0:0:0: [sdb] Mode Sense: 5f 00 00 08
[28165.873515] sd 13:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[28165.873756] sd 13:0:0:0: [sdb] Optimal transfer size 33553920 bytes not a multiple of physical block size (4096 bytes)
[28166.068149] usb 2-1: USB disconnect, device number 103
[28166.068323] usb 2-1: cmd cmplt err -108
[28166.068331] xhci_hcd 0000:00:14.0: WARN Set TR Deq Ptr cmd failed due to incorrect slot or ep state.
[28166.068391] sd 13:0:0:0: tag#4 uas_zap_pending 0 uas-tag 1 inflight: CMD 
[28166.068396] sd 13:0:0:0: tag#4 CDB: Test Unit Ready 00 00 00 00 00 00
[28166.268276] sd 13:0:0:0: [sdb] Read Capacity(16) failed: Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
[28166.268281] sd 13:0:0:0: [sdb] Sense not available.
[28166.468254] sd 13:0:0:0: [sdb] Read Capacity(10) failed: Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
[28166.468259] sd 13:0:0:0: [sdb] Sense not available.
[28166.554956] sd 13:0:0:0: [sdb] 0 512-byte logical blocks: (0 B/0 B)
[28166.554962] sd 13:0:0:0: [sdb] 4096-byte physical blocks
[28166.728277] sdb: detected capacity change from 128035676160 to 0
[28166.994947] sd 13:0:0:0: [sdb] Read Capacity(16) failed: Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
[28166.994952] sd 13:0:0:0: [sdb] Sense not available.
[28167.201616] sd 13:0:0:0: [sdb] Read Capacity(10) failed: Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
[28167.201622] sd 13:0:0:0: [sdb] Sense not available.
[28167.454955] sd 13:0:0:0: [sdb] Attached SCSI disk
[28175.214997] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28186.798446] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28187.528446] usb 2-1: new SuperSpeed Gen 1 USB device number 104 using xhci_hcd
[28187.545781] usb 2-1: New USB device found, idVendor=152d, idProduct=0562, bcdDevice= 2.04
[28187.545789] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[28187.545794] usb 2-1: Product: USB3.1 TO NVME SSD
[28187.545798] usb 2-1: Manufacturer: Liangteng
[28187.545803] usb 2-1: SerialNumber: DD20180910888
[28187.551139] scsi host13: uas
[28187.551951] scsi 13:0:0:0: Direct-Access     ITHOO    Tech             0204 PQ: 0 ANSI: 6
[28187.552706] sd 13:0:0:0: Attached scsi generic sg2 type 0
[28187.553606] sd 13:0:0:0: [sdb] 250069680 512-byte logical blocks: (128 GB/119 GiB)
[28187.553612] sd 13:0:0:0: [sdb] 4096-byte physical blocks
[28187.553751] sd 13:0:0:0: [sdb] Write Protect is off
[28187.553756] sd 13:0:0:0: [sdb] Mode Sense: 5f 00 00 08
[28187.553960] sd 13:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[28187.554163] sd 13:0:0:0: [sdb] Optimal transfer size 33553920 bytes not a multiple of physical block size (4096 bytes)
[28189.415076] usb 2-1: USB disconnect, device number 104
[28189.415246] usb 2-1: cmd cmplt err -108
[28189.415254] xhci_hcd 0000:00:14.0: WARN Set TR Deq Ptr cmd failed due to incorrect slot or ep state.
[28189.415333] sd 13:0:0:0: tag#3 uas_zap_pending 0 uas-tag 1 inflight: CMD 
[28189.415338] sd 13:0:0:0: tag#3 CDB: Test Unit Ready 00 00 00 00 00 00
[28189.615153] sd 13:0:0:0: [sdb] Read Capacity(16) failed: Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
[28189.615159] sd 13:0:0:0: [sdb] Sense not available.
[28189.815156] sd 13:0:0:0: [sdb] Read Capacity(10) failed: Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
[28189.815162] sd 13:0:0:0: [sdb] Sense not available.
[28189.898477] sd 13:0:0:0: [sdb] 0 512-byte logical blocks: (0 B/0 B)
[28189.898481] sd 13:0:0:0: [sdb] 4096-byte physical blocks
[28190.071820] sdb: detected capacity change from 128035676160 to 0
[28190.338477] sd 13:0:0:0: [sdb] Read Capacity(16) failed: Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
[28190.338483] sd 13:0:0:0: [sdb] Sense not available.
[28190.538500] sd 13:0:0:0: [sdb] Read Capacity(10) failed: Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
[28190.538506] sd 13:0:0:0: [sdb] Sense not available.
[28190.791840] sd 13:0:0:0: [sdb] Attached SCSI disk
[28199.471894] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28204.665275] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28209.008647] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28212.048663] usb 2-1: new SuperSpeed Gen 1 USB device number 105 using xhci_hcd
[28212.066008] usb 2-1: New USB device found, idVendor=152d, idProduct=0562, bcdDevice= 2.04
[28212.066017] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[28212.066023] usb 2-1: Product: USB3.1 TO NVME SSD
[28212.066028] usb 2-1: Manufacturer: Liangteng
[28212.066032] usb 2-1: SerialNumber: DD20180910888
[28212.071230] scsi host13: uas
[28212.071903] scsi 13:0:0:0: Direct-Access     ITHOO    Tech             0204 PQ: 0 ANSI: 6
[28212.072654] sd 13:0:0:0: Attached scsi generic sg2 type 0
[28212.073388] sd 13:0:0:0: [sdb] 250069680 512-byte logical blocks: (128 GB/119 GiB)
[28212.073394] sd 13:0:0:0: [sdb] 4096-byte physical blocks
[28212.073520] sd 13:0:0:0: [sdb] Write Protect is off
[28212.073525] sd 13:0:0:0: [sdb] Mode Sense: 5f 00 00 08
[28212.073729] sd 13:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[28212.073931] sd 13:0:0:0: [sdb] Optimal transfer size 33553920 bytes not a multiple of physical block size (4096 bytes)
[28216.688717] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28216.688738] usb 2-1: USB disconnect, device number 105
[28216.688988] sd 13:0:0:0: [sdb] tag#23 uas_zap_pending 0 uas-tag 1 inflight: CMD 
[28216.688994] sd 13:0:0:0: [sdb] tag#23 CDB: Read(10) 28 00 00 00 00 00 00 00 08 00
[28216.689046] sd 13:0:0:0: [sdb] tag#23 FAILED Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK
[28216.689051] sd 13:0:0:0: [sdb] tag#23 CDB: Read(10) 28 00 00 00 00 00 00 00 08 00
[28216.689054] print_req_error: 18 callbacks suppressed
[28216.689059] blk_update_request: I/O error, dev sdb, sector 0 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 0
[28216.689064] buffer_io_error: 1 callbacks suppressed
[28216.689066] Buffer I/O error on dev sdb, logical block 0, async page read
[28216.689183] blk_update_request: I/O error, dev sdb, sector 0 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 0
[28216.689189] Buffer I/O error on dev sdb, logical block 0, async page read
[28216.689202] ldm_validate_partition_table(): Disk read failed.
[28216.689219] blk_update_request: I/O error, dev sdb, sector 0 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 0
[28216.689223] Buffer I/O error on dev sdb, logical block 0, async page read
[28216.689240] blk_update_request: I/O error, dev sdb, sector 0 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 0
[28216.689243] Buffer I/O error on dev sdb, logical block 0, async page read
[28216.689260] blk_update_request: I/O error, dev sdb, sector 0 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 0
[28216.689263] Buffer I/O error on dev sdb, logical block 0, async page read
[28216.689269]  sdb: unable to read partition table
[28216.955426] sd 13:0:0:0: [sdb] Read Capacity(16) failed: Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
[28216.955432] sd 13:0:0:0: [sdb] Sense not available.
[28217.155407] sd 13:0:0:0: [sdb] Read Capacity(10) failed: Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
[28217.155412] sd 13:0:0:0: [sdb] Sense not available.
[28217.235418] sd 13:0:0:0: [sdb] 0 512-byte logical blocks: (0 B/0 B)
[28217.235423] sd 13:0:0:0: [sdb] 4096-byte physical blocks
[28217.408746] sd 13:0:0:0: [sdb] Attached SCSI disk
[28223.502118] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28232.452185] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28236.795550] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28240.835596] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28246.818991] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28251.329032] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28258.342429] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28265.469159] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28271.999228] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28282.249310] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28295.102764] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28297.522962] usb 2-1: Device not responding to setup address.
[28297.732737] usb 2-1: Device not responding to setup address.
[28297.939416] usb 2-1: device not accepting address 106, error -71
[28298.959461] usb 2-1: Device not responding to setup address.
[28299.169465] usb 2-1: Device not responding to setup address.
[28299.376069] usb 2-1: device not accepting address 107, error -71
[28299.376158] usb usb2-port1: attempt power cycle
[28301.392758] usb 1-1: new high-speed USB device number 66 using xhci_hcd
[28309.569560] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28313.609589] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28328.603066] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28336.559807] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28339.803151] usb 2-1: new SuperSpeed Gen 1 USB device number 109 using xhci_hcd
[28339.820599] usb 2-1: New USB device found, idVendor=152d, idProduct=0562, bcdDevice= 2.04
[28339.820605] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[28339.820609] usb 2-1: Product: USB3.1 TO NVME SSD
[28339.820612] usb 2-1: Manufacturer: Liangteng
[28339.820615] usb 2-1: SerialNumber: DD20180910888
[28339.828404] scsi host13: uas
[28339.829118] scsi 13:0:0:0: Direct-Access     ITHOO    Tech             0204 PQ: 0 ANSI: 6
[28339.830171] sd 13:0:0:0: Attached scsi generic sg2 type 0
[28339.830772] sd 13:0:0:0: [sdb] 250069680 512-byte logical blocks: (128 GB/119 GiB)
[28339.830778] sd 13:0:0:0: [sdb] 4096-byte physical blocks
[28339.830910] sd 13:0:0:0: [sdb] Write Protect is off
[28339.830915] sd 13:0:0:0: [sdb] Mode Sense: 5f 00 00 08
[28339.831193] sd 13:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[28339.831534] sd 13:0:0:0: [sdb] Optimal transfer size 33553920 bytes not a multiple of physical block size (4096 bytes)
[28339.865797]  sdb: sdb1 sdb2
[28339.866811] sd 13:0:0:0: [sdb] Attached SCSI disk
[28340.049781] usb 2-1: USB disconnect, device number 109
[28340.051647] sd 13:0:0:0: [sdb] Synchronizing SCSI cache
[28340.249809] sd 13:0:0:0: [sdb] Synchronize Cache(10) failed: Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
[28346.913236] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28351.292797] proc: Bad value for 'hidepid'
[28351.328456] audit: type=1130 audit(1616687832.662:182): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-hostnamed comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[28355.206641] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28361.540038] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28365.580058] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28369.753445] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28399.906129] audit: type=1131 audit(1616687881.238:183): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-hostnamed comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'

         [27949.779616] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[27958.059701] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[27962.563005] usb 2-1: Device not responding to setup address.
[27962.773004] usb 2-1: Device not responding to setup address.
[27962.979681] usb 2-1: device not accepting address 97, error -71
[27964.829787] usb 2-1: Device not responding to setup address.
[27965.039755] usb 2-1: Device not responding to setup address.
[27965.246367] usb 2-1: device not accepting address 98, error -71
[27965.246455] usb usb2-port1: attempt power cycle
[27969.619815] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[27977.136538] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[27981.309911] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[27985.349948] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[27992.173343] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[27992.733351] usb 2-1: new SuperSpeed Gen 1 USB device number 100 using xhci_hcd
[27992.750695] usb 2-1: New USB device found, idVendor=152d, idProduct=0562, bcdDevice= 2.04
[27992.750701] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[27992.750705] usb 2-1: Product: USB3.1 TO NVME SSD
[27992.750708] usb 2-1: Manufacturer: Liangteng
[27992.750711] usb 2-1: SerialNumber: DD20180910888
[27992.755322] scsi host13: uas
[27992.755602] scsi 13:0:0:0: Direct-Access     ITHOO    Tech             0204 PQ: 0 ANSI: 6
[27992.756009] sd 13:0:0:0: Attached scsi generic sg2 type 0
[27994.536635] usb 2-1: USB disconnect, device number 100
[27994.536829] sd 13:0:0:0: tag#5 uas_zap_pending 0 uas-tag 1 inflight: CMD 
[27994.536836] sd 13:0:0:0: tag#5 CDB: Test Unit Ready 00 00 00 00 00 00
[27994.740047] sd 13:0:0:0: [sdb] Read Capacity(16) failed: Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
[27994.740053] sd 13:0:0:0: [sdb] Sense not available.
[27994.940027] sd 13:0:0:0: [sdb] Read Capacity(10) failed: Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
[27994.940035] sd 13:0:0:0: [sdb] Sense not available.
[27995.020071] sd 13:0:0:0: [sdb] 0 512-byte logical blocks: (0 B/0 B)
[27995.020076] sd 13:0:0:0: [sdb] 0-byte physical blocks
[27995.086718] sd 13:0:0:0: [sdb] Write Protect is off
[27995.086724] sd 13:0:0:0: [sdb] Mode Sense: 00 00 00 00
[27995.153389] sd 13:0:0:0: [sdb] Asking for cache data failed
[27995.153395] sd 13:0:0:0: [sdb] Assuming drive cache: write through
[27995.583395] sd 13:0:0:0: [sdb] Read Capacity(16) failed: Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
[27995.583400] sd 13:0:0:0: [sdb] Sense not available.
[27995.783396] sd 13:0:0:0: [sdb] Read Capacity(10) failed: Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
[27995.783402] sd 13:0:0:0: [sdb] Sense not available.
[27996.116733] sd 13:0:0:0: [sdb] Attached SCSI disk
[28000.403421] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28004.446787] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28008.620161] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28012.660199] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28016.833566] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28022.540260] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28029.777038] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28039.027104] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28045.670502] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28050.317265] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28054.357241] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[28055.913914] usb 2-1: new SuperSpeed Gen 1 USB device number 101 using xhci_hcd
[28061.057336] usb 2-1: New USB device found, idVendor=152d, idProduct=0562, bcdDevice= 2.04
[28061.057342] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[28061.227242] usb 2-1: USB disconnect, device number 101
3
  • Looks like your chinese USB to NVME converter is either dead or contains some hardware linux can't cope with. – kanehekili Mar 25 at 18:58
  • Looks like a broken USB adapter – roaima Mar 25 at 20:52
  • Looks like I was stupidly overconfident about the cable! I turned the type-C end round and plugged it back into the housing and everything's fine again. I'd still like to know how to understand the dmesg log better - clearly some connection was being made, and that's what led me to believe it must be a software problem. – Nick C Mar 26 at 7:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.