3

On updating my Flatpak with flatpak update, I get following message:

Info: org.gnome.Platform//3.36 is end-of-life, with reason:
   The GNOME 3.36 runtime is no longer supported as of February 13, 2021. Please ask your application developer to migrate to a supported platform.
Applications using this runtime:
   org.gimp.GIMP

I have tried flatpak repair to no avail.

Do you know how I can correct this problem? Should I really contact the developers of GNOME 3.36? Thanks.

By the way my OS is Linux Ubuntu 16.04. LTS (in case it matters)

1 Answer 1

2

You can work around this by running

flatpak run --runtime-version=3.38 org.gimp.GIMP

To get it fixed properly,

Please ask your application developer to migrate to a supported platform.

means that you should contact the GIMP developers, not the GNOME developers. But that’s already been done, see issue 84 in the GIMP flathub repository.

2
  • Thanks, specially for the link a very useful thread. By the way, as the version 40 is already out, they recommend flatpak run --runtime-version=40 org.gimp.GIMP. Both work in my case, but I guess that using the last version is advisable. Mar 25, 2021 at 11:41
  • 1
    Well, “they recommend” is a bit of a stretch, one person mentioned it (or perhaps you’re referring to some other recommendation somewhere else). In such circumstances I tend to favour using the lowest supported version, to minimise the risk of disruption. Mar 25, 2021 at 12:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .