0

I'm using centos 8.3.2011 and after "yum install maven" I get

maven-3.5.4-5.module_el8.0.0+39+6a9b6e22.noarch 

I'm trying to update on the latest version, but "yum update" is not seeing it :-(

"yum -v repolist" shows repositories that have it.

http://mirror.centos.plus.hr/centos/8.3.2011/AppStream/x86_64/os/Packages/

maven-3.5.4-5.module_el8.0.0+39+6a9b6e22.noarch <-- installed
maven-3.6.2-5.module_el8.3.0+397+dd71f484.noarch <-- I would like this version

"yum clean all" is not helping :-(

What I'm I doing wrong? Thanks!

2
  • Have you tried removing the existing version and installing the specific version of the package that you want, i.e. yum install maven-3.6.2-5.module_el8.3.0 – fpmurphy Mar 25 at 10:40
  • @fpmurphy yes, but it's not possible. I found a solution, I'll post it now. – fritz Mar 25 at 10:42
1

It looks like this is the right way.

Before installing maven, I should switch the version to 3.6 using this:

dnf -y module enable maven:3.6

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.